dev-python/jaraco-envs: Bump to 2.0.0
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:15:44 +0000 (09:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:15:44 +0000 (09:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jaraco-envs/Manifest
dev-python/jaraco-envs/jaraco-envs-2.0.0.ebuild [new file with mode: 0644]

index 5183167997a34b4e867e165e8428ae53d123412a..1d40f9f51cd054f1af808223e768836d1005aa3a 100644 (file)
@@ -1 +1,2 @@
 DIST jaraco-envs-1.0.1.tar.gz 8133 BLAKE2B 05ec6b0ea7532dcf6efe32fe7d1d6a1346d60294ed09743a6f7a47599406bb798f1250525b241aa24b971849f485f89440a56e8ca6b94b2f6847c48aab281be8 SHA512 df5aa3fe06be5091745697cb5f9dda6110fa60e1330515dddbb3e8441eb2232ba1036cfaef7ac8f054958c1a890601330b04b81a0887c4ebc6b41f29335df76b
+DIST jaraco-envs-2.0.0.tar.gz 8889 BLAKE2B 33635b4eae84dd01c7ca6f41ca38b73cc10f0c131788481349019e11e3a0fdf20039574fa99678fc9f8cbe0082c817997e944bf3299fed05b0ca4a68a24e2ec2 SHA512 a834f72ae5b3e0633f1d794a28914e653807ba27a9184724a651ed8ee7d8d0541fef6d5888a47ac53f386dcd8b701d305ae68ddcf56bec5992e49272a641ea38
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.0.0.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..9a758d4
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Classes for orchestrating Python (virtual) environments."
+HOMEPAGE="https://github.com/jaraco/jaraco.envs"
+SRC_URI="https://github.com/jaraco/jaraco.envs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~sparc ~x86"
+
+RDEPEND="dev-python/namespace-jaraco[${PYTHON_USEDEP}]
+       dev-python/path-py[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' 'python3_[67]')"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# there are no actual tests, just flake8 etc
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+       # avoid a setuptools_scm dependency
+       sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+       sed -r -i "s:setuptools(_|-)scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
+               setup.cfg || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_install() {
+       rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+       distutils-r1_python_install --skip-build
+}