media-sound/pms: migrate live ebuild to cmake
authorMykyta Holubakha <hilobakho@gmail.com>
Tue, 4 Apr 2017 12:32:12 +0000 (15:32 +0300)
committerDavid Seifert <soap@gentoo.org>
Sat, 8 Apr 2017 14:59:53 +0000 (16:59 +0200)
remove extraneous patch
Closes: https://github.com/gentoo/gentoo/pull/4356

media-sound/pms/files/pms-9999-fix-automagic-dep.patch [deleted file]
media-sound/pms/pms-9999.ebuild

diff --git a/media-sound/pms/files/pms-9999-fix-automagic-dep.patch b/media-sound/pms/files/pms-9999-fix-automagic-dep.patch
deleted file mode 100644 (file)
index afb71d1..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From 3771a139059cf248cc07cf8a735c0cd95ae3c6af Mon Sep 17 00:00:00 2001
-From: Mykyta Holubakha <hilobakho@gmail.com>
-Date: Fri, 9 Sep 2016 00:56:22 +0300
-Subject: [PATCH] Fix automagic pandoc dependency
-
----
- configure.ac | 11 ++++++++---
- 1 file changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 45e6d1a..aea9285 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -25,9 +25,14 @@ PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.0],, [AC_MSG_ERROR([glib 2.0 or newer i
- PKG_CHECK_MODULES([libmpdclient], [libmpdclient >= 2.5],, [AC_MSG_ERROR([libmpdclient 2.5 or newer is required])])
- # Check for Pandoc
--AC_PATH_PROG(PANDOC,pandoc,no)
--if [[ "x$PANDOC" = xno ]]; then
--    AC_MSG_WARN([The manual page will not be built.])
-+AC_ARG_WITH([doc], AS_HELP_STRING([--with-doc],[Build the manpage (default: disabled)]))
-+if [test "x$with_doc" = "xyes"]; then
-+      AC_PATH_PROG(PANDOC,pandoc,no)
-+      if [[ "x$PANDOC" = xno ]]; then
-+          AC_MSG_WARN([The manual page will not be built.])
-+      fi
-+else
-+      PANDOC="no"
- fi
- AM_CONDITIONAL([PANDOC], [test "x$PANDOC" != xno])
--- 
-2.10.0
-
index c4873bce0ccbdf424aafd0a1808487d55730619c..6d7622c10d99c5475a5247ac995dbeaca1046c03 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit autotools flag-o-matic git-r3 toolchain-funcs versionator
+inherit cmake-utils git-r3
 
 DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
 HOMEPAGE="https://ambientsound.github.io/pms"
@@ -12,45 +12,24 @@ EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
 LICENSE="GPL-3+"
 SLOT="0"
 KEYWORDS=""
-IUSE="regex doc"
+IUSE="+regex doc"
 
 RDEPEND="
        sys-libs/ncurses:0=[unicode]
        dev-libs/glib:2
        media-libs/libmpdclient
-       virtual/libintl
 "
 DEPEND="
        virtual/pkgconfig
-       dev-util/intltool
-       sys-devel/gettext
        doc? ( app-text/pandoc )
        ${RDEPEND}
 "
 
-DOCS=( AUTHORS README TODO )
-
-pkg_pretend() {
-       if [[ ${MERGE_TYPE} != binary ]] && use regex; then
-               if tc-is-gcc && ! version_is_at_least 4.9 $(gcc-version); then
-                       die "Clang or GCC >= 4.9 is required for proper regex support"
-               fi
-       fi
-}
-
-src_prepare() {
-       eapply "${FILESDIR}/pms-9999-fix-automagic-dep.patch"
-       eapply_user
-
-       eautoreconf
-}
-
 src_configure() {
-       # Required for ncurses[tinfo]
-       append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
-       append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
+       local mycmakeargs=(
+               -DENABLE_DOC=$(usex doc)
+               -DENABLE_REGEX=$(usex regex)
+       )
 
-       econf \
-               $(use_enable regex) \
-               $(use_with doc)
+       cmake-utils_src_configure
 }