dev-python/args: EAPI=7
authorCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 20:19:48 +0000 (16:19 -0400)
committerCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 20:23:14 +0000 (16:23 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/args/args-0.1.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/args/args-0.1.0-r1.ebuild b/dev-python/args/args-0.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..228d6f7
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Arguments for Humans"
+HOMEPAGE="https://github.com/kennethreitz/args"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""