Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 16:31:52 +0000 (16:31 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 16:31:52 +0000 (16:31 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_dav/ChangeLog
net-www/mod_dav/mod_dav-1.0.3-r3.ebuild

index dfe927e2c62f5b3f01c6ea9f1eb327192a580775..22b03ed10db63dd23dcb66954f93d7e983681113 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-www/mod_dav
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_dav/ChangeLog,v 1.23 2006/06/04 19:38:37 vericgar Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_dav/ChangeLog,v 1.24 2007/01/14 16:31:52 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org> -files/mod_dav.conf,
+  mod_dav-1.0.3-r3.ebuild:
+  Cleanup, fix autotools usage.
 
   04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
   -mod_dav-1.0.3-r1.ebuild, -mod_dav-1.0.3-r2.ebuild:
index 677970b0b37472c2493c487ddc8d02d4db7a0dff..bf747cca35d5655d2be6b2bd923ddb9a9b3c7406 100644 (file)
@@ -1,22 +1,24 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_dav/mod_dav-1.0.3-r3.ebuild,v 1.4 2005/10/12 19:30:08 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_dav/mod_dav-1.0.3-r3.ebuild,v 1.5 2007/01/14 16:31:52 chtekk Exp $
 
-inherit eutils apache-module
+inherit eutils autotools apache-module
 
 MY_V=${PV}-1.3.6
 
-DESCRIPTION="Apache module for Distributed Authoring and Versioning"
+DESCRIPTION="Apache module for Distributed Authoring and Versioning."
 HOMEPAGE="http://www.webdav.org/mod_dav/"
 SRC_URI="http://www.webdav.org/mod_dav/${PN}-${MY_V}.tar.gz"
 
 KEYWORDS="~amd64 ppc sparc x86"
-DEPEND=""
 LICENSE="as-is"
 SLOT="0"
 IUSE=""
 
-S=${WORKDIR}/${PN}-${MY_V}
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_V}"
 
 DOCFILES="LICENSE.html README CHANGES INSTALL"
 
@@ -27,20 +29,19 @@ APACHE1_MOD_DEFINE="DAV"
 need_apache1
 
 src_unpack() {
-       unpack ${A} || die
-       cd ${S} || die
-       epatch ${FILESDIR}/${PN}-shared-expat.patch || die
-       epatch ${FILESDIR}/mod_dav_fs_lock.patch || die
-       autoconf || die
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${PN}-shared-expat.patch"
+       epatch "${FILESDIR}/${PN}_fs_lock.patch"
+       eautoconf
 }
 
 src_compile() {
-       ./configure --host=${CHOST} || die
-       emake || die "compile problem"
+       econf || die "econf failed"
+       emake || die "emake failed"
 }
 
 pkg_postinst() {
-       # empty lock dir
-       install -m0750 -o apache -g apache -d ${ROOT}/var/lock/mod_dav
+       install -m0750 -o apache -g apache -d "${ROOT}"/var/lock/mod_dav
        apache1_pkg_postinst
 }