net-misc/axel: remove unused patch(es)
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Wed, 15 Apr 2020 16:20:46 +0000 (18:20 +0200)
committerAaron Bauman <bman@gentoo.org>
Thu, 14 May 2020 22:19:24 +0000 (18:19 -0400)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15358
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-misc/axel/files/axel-2.4-bffr-overflow.patch [deleted file]
net-misc/axel/files/axel-2.4-buildsystem.patch [deleted file]
net-misc/axel/files/axel-2.4-max-redir.patch [deleted file]

diff --git a/net-misc/axel/files/axel-2.4-bffr-overflow.patch b/net-misc/axel/files/axel-2.4-bffr-overflow.patch
deleted file mode 100644 (file)
index 24fae8c..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
- http.c |    2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/http.c b/http.c
-index 5d64e9b..db91701 100644
---- a/http.c
-+++ b/http.c
-@@ -164,7 +164,7 @@ int http_exec( http_t *conn )
-               {
-                       i ++;
-               }
--              strncat( conn->headers, s, MAX_QUERY );
-+              strncat( conn->headers, s, MAX_QUERY - 1);
-       }
- #ifdef DEBUG
diff --git a/net-misc/axel/files/axel-2.4-buildsystem.patch b/net-misc/axel/files/axel-2.4-buildsystem.patch
deleted file mode 100644 (file)
index a1571f0..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
- Makefile |    4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 1c3863a..b43fcff 100644
---- a/Makefile
-+++ b/Makefile
-@@ -51,13 +51,13 @@ uninstall-etc:
- ### MAIN PROGRAM
- $(OUTFILE): axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o
--      $(CC) *.o -o $(OUTFILE) $(LFLAGS)
-+      $(CC) $(LDFLAGS) *.o -o $(OUTFILE) $(LFLAGS)
- ifndef DEBUG
-       -$(STRIP) $(OUTFILE)
- endif
- .c.o:
--      $(CC) -c $*.c -o $*.o -Wall $(CFLAGS)
-+      $(CC) $(CPPFLAGS) -c $*.c -o $*.o -Wall $(CFLAGS)
- install-bin:
-       mkdir -p $(DESTDIR)$(BINDIR)/
diff --git a/net-misc/axel/files/axel-2.4-max-redir.patch b/net-misc/axel/files/axel-2.4-max-redir.patch
deleted file mode 100644 (file)
index f52796c..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
- axel.h |    2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/axel.h b/axel.h
-index e90d30d..f6ebfe8 100644
---- a/axel.h
-+++ b/axel.h
-@@ -66,7 +66,7 @@
- /* Compiled-in settings                                                       */
- #define MAX_STRING            1024
- #define MAX_ADD_HEADERS       10
--#define MAX_REDIR             5
-+#define MAX_REDIR             25
- #define AXEL_VERSION_STRING   "2.4"
- #define DEFAULT_USER_AGENT    "Axel " AXEL_VERSION_STRING " (" ARCH ")"