dev-haskell/graphviz: bump up to 2999.18.1.2
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 23:02:09 +0000 (23:02 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 10:21:43 +0000 (10:21 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/graphviz/Manifest
dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild [new file with mode: 0644]

index 6b4b60c338febdb4a323c139298ac5414c0e4e2b..d720dc25e8e4799c5b73042c8cc552070849f55b 100644 (file)
@@ -1 +1,2 @@
 DIST graphviz-2999.18.0.2.tar.gz 223908 SHA256 0ce1dca248e549b005798472cc6b906143369d987cf482fc0435b1029e5cc567 SHA512 8b27a81af2d31780801534f785bfda1dfbd127e176fa2c4bada2b33a7c80166fbb0efa67706296201bb19d201b8e2ac56453be0d8fcb488b93feb95d2acd8a09 WHIRLPOOL d88550711ea99c586d6a272c3a99c12ccf91cf096e80585d6f61c71bbb3dc6842e9876632823ca096325a97253a62ab16f85a7f7055cb8593ed8b87d206c08ec
+DIST graphviz-2999.18.1.2.tar.gz 222546 SHA256 b08c2026d3810c15f6ad49a07fd7b879978d958fa477b369b719ec00741c85fc SHA512 1e0bc5b72b934febb923c13052f83db12270954e37483f46c64db8a23eb7ea3894b72c8e2cb303cde6bec30f75a28897c53d81e92fe9489ec21a4589e648dd3f WHIRLPOOL 392ece9feba823c706fd8dbaa90686b9c63c3724d95ffe31508fea6050802e2320d53b54562375d44b543634f15fcc2f70fb99848e05ba1486c12669062e7e4b
diff --git a/dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild b/dev-haskell/graphviz/graphviz-2999.18.1.2.ebuild
new file mode 100644 (file)
index 0000000..8e46283
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -test-parsing
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to Graphviz for graph visualisation"
+HOMEPAGE="http://projects.haskell.org/graphviz/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/colour-2.3:=[profile?] <dev-haskell/colour-2.4:=[profile?]
+       >=dev-haskell/dlist-0.5:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
+       >=dev-haskell/fgl-5.4:=[profile?] <dev-haskell/fgl-5.6:=[profile?]
+       >=dev-haskell/polyparse-1.9:=[profile?] <dev-haskell/polyparse-1.13:=[profile?]
+       >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+       dev-haskell/text:=[profile?]
+       >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+       >=dev-haskell/wl-pprint-text-1.1.0.0:=[profile?] <dev-haskell/wl-pprint-text-1.2.0.0:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.14
+       test? ( >=dev-haskell/fgl-arbitrary-0.2 <dev-haskell/fgl-arbitrary-0.3
+               >=dev-haskell/quickcheck-2.3 <dev-haskell/quickcheck-2.10 )
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=-test-parsing
+}