app-emulation/libpod: Bump to version 1.6.2
authorZac Medico <zmedico@gentoo.org>
Fri, 18 Oct 2019 05:15:46 +0000 (22:15 -0700)
committerZac Medico <zmedico@gentoo.org>
Fri, 18 Oct 2019 05:30:04 +0000 (22:30 -0700)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-emulation/libpod/Manifest
app-emulation/libpod/libpod-1.6.2.ebuild [new file with mode: 0644]

index d81a0348f34d3b8756997095ff219046b58db14f..240231492099818dbd37f89a257d84bffc3137c7 100644 (file)
@@ -1 +1,2 @@
 DIST libpod-1.5.1.tar.gz 8010274 BLAKE2B 4928b45a6d86fe14ff7359c856da664d14fc578dcff095c984eb0fa3b4aed42576cf610f19a9015064f406109d79cd6df60eb0b2990e5058de1e4f9f7d9ae7ee SHA512 d9d422c4189adb840cfe3dd8b7e8278412f0ea17e4ccd2cdf4f4b134a87b1add61bbdca1c8d9db3db846c272e2ab3f624bf9e4aac005b78d0c7e161af898dc02
+DIST libpod-1.6.2.tar.gz 8270781 BLAKE2B 5d86533ddc821f731292e126102a31d651956c275a22c5c4ab3c57b9351832a1d85d75be877343c60af47716f9d1776315b3bf41fb17037d02fee10cf88efba3 SHA512 68192dda019623e3f3af9f82f946be8efbaf3e2c54acf23f62af67ac1ca093dd4dba11d2a7c1c950b99060393ed7e945752c1eaa9eada0dfc30f3dcaac8e1c04
diff --git a/app-emulation/libpod/libpod-1.6.2.ebuild b/app-emulation/libpod/libpod-1.6.2.ebuild
new file mode 100644 (file)
index 0000000..9c1a415
--- /dev/null
@@ -0,0 +1,142 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="f3ffda1e08f19e9a6a88484136b5eed76533f21a"
+EGO_PN="github.com/containers/${PN}"
+
+inherit bash-completion-r1 flag-o-matic golang-vcs-snapshot
+
+DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
+HOMEPAGE="https://github.com/containers/libpod/"
+SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="apparmor btrfs ostree +rootless selinux"
+REQUIRED_USE="!selinux? ( !ostree )"
+RESTRICT="test"
+
+COMMON_DEPEND="
+       app-crypt/gpgme:=
+       >=app-emulation/conmon-2.0.0
+       >=app-emulation/runc-1.0.0_rc6
+       dev-libs/libassuan:=
+       dev-libs/libgpg-error:=
+       sys-fs/lvm2
+       sys-libs/libseccomp:=
+
+       apparmor? ( sys-libs/libapparmor )
+       btrfs? ( sys-fs/btrfs-progs )
+       ostree? (
+               dev-libs/glib:=
+               dev-util/ostree:=
+       )
+       rootless? ( app-emulation/slirp4netns )
+       selinux? ( sys-libs/libselinux:= )
+"
+DEPEND="
+       ${COMMON_DEPEND}
+       dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+       default
+
+       # Disable installation of python modules here, since those are
+       # installed by separate ebuilds.
+       sed -e '/^GIT_.*/d' \
+               -e 's/$(GO) build/$(GO) build -v -work -x/' \
+               -e 's/^\(install:.*\) install\.python$/\1/' \
+               -i Makefile || die
+}
+
+src_compile() {
+       # Filter unsupported linker flags
+       filter-flags '-Wl,*'
+
+       [[ -f hack/apparmor_tag.sh ]] || die
+       if use apparmor; then
+               echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
+       else
+               echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
+       fi
+
+       [[ -f hack/btrfs_installed_tag.sh ]] || die
+       if use btrfs; then
+               echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
+       else
+               echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+                       hack/btrfs_installed_tag.sh || die
+       fi
+
+       [[ -f hack/ostree_tag.sh ]] || die
+       if use ostree; then
+               echo -e "#!/bin/sh\necho ostree" > hack/ostree_tag.sh || die
+       else
+               echo -e "#!/bin/sh\necho containers_image_ostree_stub" > hack/ostree_tag.sh || die
+       fi
+
+       [[ -f hack/selinux_tag.sh ]] || die
+       if use selinux; then
+               echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
+       else
+               echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
+       fi
+
+       env -u GOCACHE -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
+               emake all \
+                       GIT_BRANCH=master \
+                       GIT_BRANCH_CLEAN=master \
+                       COMMIT_NO="${EGIT_COMMIT}" \
+                       GIT_COMMIT="${EGIT_COMMIT}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+       insinto /etc/containers
+       newins test/registries.conf registries.conf.example
+       newins test/policy.json policy.json.example
+
+       newinitd "${FILESDIR}"/podman.initd podman
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/podman.logrotated" podman
+
+       dobashcomp completions/bash/*
+
+       keepdir /var/lib/containers
+}
+
+pkg_preinst() {
+       LIBPOD_ROOTLESS_UPGRADE=false
+       if use rootless; then
+               has_version 'app-emulation/libpod[rootless]' || LIBPOD_ROOTLESS_UPGRADE=true
+       fi
+}
+
+pkg_postinst() {
+       local want_newline=false
+       if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
+               elog "You need to create the following config files:"
+               elog "/etc/containers/registries.conf"
+               elog "/etc/containers/policy.json"
+               elog "To copy over default examples, use:"
+               elog "cp /etc/containers/registries.conf{.example,}"
+               elog "cp /etc/containers/policy.json{.example,}"
+               want_newline=true
+       fi
+       if [[ ${LIBPOD_ROOTLESS_UPGRADE} == true ]] ; then
+               ${want_newline} && elog ""
+               elog "For rootless operation, you need to configure subuid/subgid"
+               elog "for user running podman. In case subuid/subgid has only been"
+               elog "configured for root, run:"
+               elog "usermod --add-subuids 1065536-1131071 <user>"
+               elog "usermod --add-subgids 1065536-1131071 <user>"
+               want_newline=true
+       fi
+}