games-puzzle/world-of-goo-hb: Fix bad usex usage on x86
authorJames Le Cuirot <chewi@gentoo.org>
Thu, 30 Apr 2020 23:34:58 +0000 (00:34 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 30 Apr 2020 23:38:14 +0000 (00:38 +0100)
Closes: https://bugs.gentoo.org/720186
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-puzzle/world-of-goo-hb/world-of-goo-hb-1.53.ebuild

index f08ef5823bf23aebc9fb352cd8a432b8807b04c7..01269cea57502ef8d46fedff36f90da7f4e01941 100644 (file)
@@ -51,12 +51,12 @@ src_unpack() {
 
 src_install() {
        exeinto "${dir}"
-       newexe data/x86$(usex amd64 _64)/${MY_PN}.bin.x86$(usex amd64 _64) ${MY_PN}.bin
+       newexe data/x86$(usex amd64 _64 "")/${MY_PN}.bin.x86$(usex amd64 _64 "") ${MY_PN}.bin
        dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN%-*}
 
        insinto "${dir}"
        doins -r data/noarch/game/
-       use bundled-libs && doins -r data/x86$(usex amd64 _64)/lib$(usex amd64 64)/
+       use bundled-libs && doins -r data/x86$(usex amd64 _64 "")/lib$(usex amd64 64 "")/
 
        newicon -s 256 data/noarch/game/gooicon.png ${PN%-*}.png
        make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}