media-gfx/graphicsmagick: drop vulnerable
authorAaron Bauman <bman@gentoo.org>
Mon, 4 May 2020 01:29:02 +0000 (21:29 -0400)
committerAaron Bauman <bman@gentoo.org>
Mon, 4 May 2020 01:29:02 +0000 (21:29 -0400)
Bug: https://bugs.gentoo.org/714240
Signed-off-by: Aaron Bauman <bman@gentoo.org>
media-gfx/graphicsmagick/Manifest
media-gfx/graphicsmagick/graphicsmagick-1.3.32.ebuild [deleted file]
media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild [deleted file]

index 05115965b674e72e10b4cc6be129ccb0f75eaa30..5c6174e3fae939c590b97693dd92644a001ed456 100644 (file)
@@ -1,3 +1 @@
-DIST GraphicsMagick-1.3.32.tar.xz 5535224 BLAKE2B 96fd7bfe62b4b1b25f9ffc0ff8e2ac023f0528b9af857fc27a5a9cd1123eeb6533b868c7bad8dca5b58e114a674dda009a62904df64622d7b5f3c0d72156283d SHA512 f84cdb9318962aed1dc25d70db4d0ca102e4f88748f468f8a56b77d228fd315b772afa48e90a396d32e8226eba9105717bcb94166bbe43723afeec58ead53e09
-DIST GraphicsMagick-1.3.33.tar.xz 5558348 BLAKE2B 9c3747ee63d94bc6d16c06c04c7fad2ca93e849df7ae4391523b416111b5569c7493226f6b967a5ff80e0ff2ccbe7f6de5a7223e935024fd66a96be401fdf26b SHA512 8afeb461d1a9dab9b88b9bc7c2d50b5c409463b369e6b0ba7ee39b0ece32da9393d7a5a4d18faf8f72a529346a3477bae61b802bac2af81aeae79d95c9d6cd13
 DIST GraphicsMagick-1.3.35.tar.xz 5543224 BLAKE2B 8a284d85341c10939fdece5c565d5b881276afb9b4c5dfb2221b780a01b99f78ee62761722c372baf9155c63f7ef176b67310aeedcab0368f4f26f5b0150bcce SHA512 baae92089d52147ef961f93495abc8a9d8b1a963af61d87a650c1ab105d46816aa38c83f654edcb5a0e1b7f07ccc06eaeaa443b9bde3a63a0b9bfb45f3ae144c
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.32.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.32.ebuild
deleted file mode 100644 (file)
index 38979f2..0000000
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools toolchain-funcs
-
-MY_P=${P/graphicsm/GraphicsM}
-
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/"
-LICENSE="MIT"
-SLOT="0/${PV%.*}"
-
-if [[ ${PV} == "9999" ]] ; then
-       inherit mercurial
-       EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
-else
-       SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
-       KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-fi
-
-IUSE="bzip2 +cxx debug fpx imagemagick jbig jpeg lcms lzma modules openmp
-       perl png postscript q16 q32 static-libs svg threads tiff truetype
-       webp wmf X zlib"
-
-RDEPEND="dev-libs/libltdl:0
-       bzip2? ( app-arch/bzip2 )
-       fpx? ( media-libs/libfpx )
-       imagemagick? ( !media-gfx/imagemagick )
-       jbig? ( media-libs/jbigkit )
-       jpeg? ( virtual/jpeg:0 )
-       lcms? ( media-libs/lcms:2 )
-       lzma? ( app-arch/xz-utils )
-       perl? ( dev-lang/perl:= )
-       png? ( media-libs/libpng:0= )
-       postscript? ( app-text/ghostscript-gpl )
-       svg? ( dev-libs/libxml2 )
-       tiff? ( media-libs/tiff:0 )
-       truetype? (
-               media-fonts/urw-fonts
-               >=media-libs/freetype-2
-               )
-       webp? ( media-libs/libwebp:= )
-       wmf? ( media-libs/libwmf )
-       X? (
-               x11-libs/libSM
-               x11-libs/libXext
-               )
-       zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.3.19-flags.patch
-       "${FILESDIR}"/${PN}-1.3.19-perl.patch
-)
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_configure() {
-       local depth=8
-       use q16 && depth=16
-       use q32 && depth=32
-
-       local openmp=disable
-       if use openmp && tc-has-openmp; then
-               openmp=enable
-       fi
-
-       local myeconfargs=(
-               --${openmp}-openmp
-               --enable-largefile
-               --enable-shared
-               $(use_enable static-libs static)
-               $(use_enable debug prof)
-               $(use_enable debug gcov)
-               $(use_enable imagemagick magick-compat)
-               $(use_with threads)
-               $(use_with modules)
-               --with-quantum-depth=${depth}
-               --without-frozenpaths
-               $(use_with cxx magick-plus-plus)
-               $(use_with perl)
-               --with-perl-options=INSTALLDIRS=vendor
-               $(use_with bzip2 bzlib)
-               $(use_with postscript dps)
-               $(use_with fpx)
-               $(use_with jbig)
-               $(use_with webp)
-               $(use_with jpeg)
-               --without-jp2
-               $(use_with lcms lcms2)
-               $(use_with lzma)
-               $(use_with png)
-               $(use_with tiff)
-               $(use_with truetype ttf)
-               $(use_with wmf)
-               --with-fontpath="${EPREFIX}"/usr/share/fonts
-               --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
-               --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
-               $(use_with svg xml)
-               $(use_with zlib)
-               $(use_with X x)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_compile() {
-       default
-       use perl && emake perl-build
-}
-
-src_test() {
-       unset DISPLAY # some perl tests fail when DISPLAY is set
-       default
-}
-
-src_install() {
-       default
-
-       if use perl; then
-               emake -C PerlMagick DESTDIR="${D}" install
-               find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
-               find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
-       fi
-
-       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
-}
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.33.ebuild
deleted file mode 100644 (file)
index 6e0e9fc..0000000
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools toolchain-funcs
-
-MY_P=${P/graphicsm/GraphicsM}
-
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/"
-LICENSE="MIT"
-SLOT="0/${PV%.*}"
-
-if [[ ${PV} == "9999" ]] ; then
-       inherit mercurial
-       EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
-else
-       SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-fi
-
-IUSE="bzip2 +cxx debug fpx imagemagick jbig jpeg lcms lzma modules openmp
-       perl png postscript q16 q32 static-libs svg threads tiff truetype
-       webp wmf X zlib"
-
-RDEPEND="dev-libs/libltdl:0
-       bzip2? ( app-arch/bzip2 )
-       fpx? ( media-libs/libfpx )
-       imagemagick? ( !media-gfx/imagemagick )
-       jbig? ( media-libs/jbigkit )
-       jpeg? ( virtual/jpeg:0 )
-       lcms? ( media-libs/lcms:2 )
-       lzma? ( app-arch/xz-utils )
-       perl? ( dev-lang/perl:= )
-       png? ( media-libs/libpng:0= )
-       postscript? ( app-text/ghostscript-gpl )
-       svg? ( dev-libs/libxml2 )
-       tiff? ( media-libs/tiff:0 )
-       truetype? (
-               media-fonts/urw-fonts
-               >=media-libs/freetype-2
-               )
-       webp? ( media-libs/libwebp:= )
-       wmf? ( media-libs/libwmf )
-       X? (
-               x11-libs/libSM
-               x11-libs/libXext
-               )
-       zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.3.19-flags.patch
-       "${FILESDIR}"/${PN}-1.3.19-perl.patch
-)
-
-src_prepare() {
-       default
-       eautoreconf
-}
-
-src_configure() {
-       local depth=8
-       use q16 && depth=16
-       use q32 && depth=32
-
-       local openmp=disable
-       if use openmp && tc-has-openmp; then
-               openmp=enable
-       fi
-
-       local myeconfargs=(
-               --${openmp}-openmp
-               --enable-largefile
-               --enable-shared
-               $(use_enable static-libs static)
-               $(use_enable debug prof)
-               $(use_enable debug gcov)
-               $(use_enable imagemagick magick-compat)
-               $(use_with threads)
-               $(use_with modules)
-               --with-quantum-depth=${depth}
-               --without-frozenpaths
-               $(use_with cxx magick-plus-plus)
-               $(use_with perl)
-               --with-perl-options=INSTALLDIRS=vendor
-               $(use_with bzip2 bzlib)
-               $(use_with postscript dps)
-               $(use_with fpx)
-               $(use_with jbig)
-               $(use_with webp)
-               $(use_with jpeg)
-               --without-jp2
-               $(use_with lcms lcms2)
-               $(use_with lzma)
-               $(use_with png)
-               $(use_with tiff)
-               $(use_with truetype ttf)
-               $(use_with wmf)
-               --with-fontpath="${EPREFIX}"/usr/share/fonts
-               --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
-               --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
-               $(use_with svg xml)
-               $(use_with zlib)
-               $(use_with X x)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_compile() {
-       default
-       use perl && emake perl-build
-}
-
-src_test() {
-       unset DISPLAY # some perl tests fail when DISPLAY is set
-       default
-}
-
-src_install() {
-       default
-
-       if use perl; then
-               emake -C PerlMagick DESTDIR="${D}" install
-               find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
-               find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
-       fi
-
-       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
-}