app-text/html2text: add live version, make myself co-maintainer
authorFabian Groffen <grobian@gentoo.org>
Sat, 4 Apr 2020 07:21:53 +0000 (09:21 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sat, 4 Apr 2020 16:00:13 +0000 (18:00 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
app-text/html2text/html2text-9999.ebuild [new file with mode: 0644]
app-text/html2text/metadata.xml

diff --git a/app-text/html2text/html2text-9999.ebuild b/app-text/html2text/html2text-9999.ebuild
new file mode 100644 (file)
index 0000000..8445f3d
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999* ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/grobian/html2text.git"
+else
+       SRC_URI=""
+       KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="https://github.com/grobian/html2text"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_prepare() {
+       default
+       tc-export CXX
+}
+
+src_compile() {
+       emake LDFLAGS="${LDFLAGS}" DEBUG="${CXXFLAGS}"
+}
+
+src_install() {
+       dobin html2text
+       doman html2text.1 html2textrc.5
+       dodoc CHANGES CREDITS KNOWN_BUGS README TODO
+}
index cd4b982119ec79035420bb7ba0544577e2e2d1e2..3e8dc87c60471cf58888a1f9f6e93c0340ec5799 100644 (file)
@@ -5,8 +5,8 @@
                <email>jazzoslav@gmail.com</email>
                <name>Jaroslav Rakhmatoullin</name>
        </maintainer>
-<maintainer type="project">
-               <email>proxy-maint@gentoo.org</email>
-               <name>Proxy Maintainers</name>
+       <maintainer type="person">
+               <email>grobian@gentoo.org</email>
+               <name>Fabian Groffen</name>
        </maintainer>
 </pkgmetadata>