media-plugins/vdr-actuator: version bump
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Fri, 27 Dec 2019 20:53:34 +0000 (21:53 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Fri, 27 Dec 2019 20:54:23 +0000 (21:54 +0100)
vdr-2.4 readdy
moved to eapi 7

Closes: https://bugs.gentoo.org/704022
Package-Manager: Portage-2.3.83, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-actuator/Manifest
media-plugins/vdr-actuator/vdr-actuator-1.2.1.ebuild
media-plugins/vdr-actuator/vdr-actuator-2.4.1_pre20181025.ebuild [new file with mode: 0644]

index 9912b0604d0740726768f4220541fdf37ab8c855..40bf0fd9d6c1d94ef7c85b5c6236b0731b211edf 100644 (file)
@@ -1 +1,2 @@
 DIST vdr-actuator-1.2.1.tgz 91343 BLAKE2B 93c29c026a7e5178e0ec71c7276f01de8afb2bf3360a654029aed6f32dc769a6fb0100900e3dd33ce7386dd09e2bf3952db66b21387346a043b8b096e0a64602 SHA512 faed02e0dfd1027e412418023caba7c257d6f7c46ebca89139436bf2769c3b928f103ab2e1d90bd0836db32356e3fa238d5fbef6c5548415cefee0f09c96fd66
+DIST vdr-actuator-2.4.1_pre20181025.tar.gz 122233 BLAKE2B f49cfe08f9201fa0d2795e12acbb2c981fbf7e91a9609930deb70d8d642ef5aec3d740af3d0613ec1f9332a5e08135ab05fd2eb4a6d1ab0da18b1b1a9378b5a8 SHA512 f2a79534d3bbb1320b75be7a870e7cce95bbd814f82bbfa61ab30bafeb333dcf3220a4f9c470f4390b691aa2cf745f565e45d776e4ae170ff940132e1dcecaac
index 5211357b3053857f9f8016a51978d37b9b406a07..858a5bac45234c7a812a1d06ddc982196d8d870b 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
 inherit vdr-plugin-2
 
@@ -12,10 +12,8 @@ SRC_URI="http://ventoso.org/luca/vdr/${P}.tgz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE=""
 
 DEPEND=">=media-video/vdr-1.7.23"
-RDEPEND="${DEPEND}"
 
 src_prepare() {
        vdr-plugin-2_src_prepare
diff --git a/media-plugins/vdr-actuator/vdr-actuator-2.4.1_pre20181025.ebuild b/media-plugins/vdr-actuator/vdr-actuator-2.4.1_pre20181025.ebuild
new file mode 100644 (file)
index 0000000..f07e610
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+GIT_VERSION="c810abffbf6dc6f1f354b0c545abe65311203fd8"
+
+DESCRIPTION="VDR plugin: control an hor. or ver. actuator attached trough the parallel port"
+HOMEPAGE="http://ventoso.org/luca/vdr/"
+SRC_URI="https://github.com/olivluca/vdr-actuator-plugin/archive/${GIT_VERSION}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=media-video/vdr-2.4"
+
+S="${WORKDIR}/${PN}-plugin-${GIT_VERSION}"
+
+src_prepare() {
+       vdr-plugin-2_src_prepare
+
+       fix_vdr_libsi_include "${S}/scanfilter.h"
+       fix_vdr_libsi_include "${S}/scanfilter.c"
+}