dev-perl/Crypt-DES: EAPI6 + Test love
authorKent Fredric <kentnl@gentoo.org>
Wed, 18 Oct 2017 22:46:12 +0000 (11:46 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 18 Oct 2017 22:46:12 +0000 (11:46 +1300)
- EAPI6
- Tests enabled
- Test deps added

Keywords:
- Dropped arm due to Crypt-CBC

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild b/dev-perl/Crypt-DES/Crypt-DES-2.70.0-r1.ebuild
new file mode 100644 (file)
index 0000000..283b274
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.07
+inherit perl-module
+
+DESCRIPTION="Perl DES encryption module"
+
+LICENSE="DES"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="test? ( dev-perl/Crypt-CBC )"
+
+export OPTIMIZE="${CFLAGS}"