dev-python/python-ldap: git-2->git-r3
authorMarty E. Plummer <hanetzer@startmail.com>
Sat, 28 Apr 2018 00:23:29 +0000 (19:23 -0500)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Apr 2018 10:29:48 +0000 (12:29 +0200)
Closes: https://bugs.gentoo.org/458558
Closes: https://github.com/gentoo/gentoo/pull/8176
Package-Manager: Portage-2.3.31, Repoman-2.3.9

dev-python/python-ldap/python-ldap-2.4.19-r1.ebuild
dev-python/python-ldap/python-ldap-2.4.32.ebuild
dev-python/python-ldap/python-ldap-9999.ebuild

index f727a2ec88fcf5449a789d51d82a942f2be5f4e0..3de4a5a0d0a36d56f622ee8a37bd69659860d6be 100644 (file)
@@ -11,11 +11,16 @@ inherit distutils-r1 multilib
 DESCRIPTION="Various LDAP-related Python modules"
 HOMEPAGE="https://www.python-ldap.org/en/latest/
        https://pypi.org/project/python-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
+fi
 
 LICENSE="PSF-2"
 SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
 IUSE="doc examples sasl ssl"
 
 # If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
index c43b6bc092cadd62dcc1ff6b5eba1cb0ac92ad36..623b5213fb846f3c03c54644e6146b6f442d99a6 100644 (file)
@@ -10,11 +10,16 @@ inherit distutils-r1 multilib
 DESCRIPTION="Various LDAP-related Python modules"
 HOMEPAGE="https://www.python-ldap.org/en/latest/
        https://pypi.org/project/python-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+fi
 
 LICENSE="PSF-2"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
 IUSE="examples sasl ssl"
 
 # If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
@@ -26,7 +31,8 @@ RDEPEND=">net-nds/openldap-2.4.11
        dev-python/pyasn1-modules[${PYTHON_USEDEP}]
        sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
 DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
 RDEPEND+=" !dev-python/pyldap"
 
 python_prepare_all() {
index 468171efb88ce3601c84b4e3c24295b660b09294..ee6ebf08e0eaa1dd1af34c863d1e288386625afa 100644 (file)
@@ -1,33 +1,39 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-# pypy: bug #458558 (wrong linker options due to not respecting CC)
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 pypy )
 
-inherit distutils-r1 git-2 multilib
+inherit distutils-r1
 
 DESCRIPTION="Various LDAP-related Python modules"
 HOMEPAGE="https://www.python-ldap.org/en/latest/
        https://pypi.org/project/python-ldap/"
-EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+if [[ ${PV} == *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+fi
 
 LICENSE="PSF-2"
 SLOT="0"
-KEYWORDS=""
 IUSE="doc examples sasl ssl"
 
 # If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
 # python team: Please do not remove python-ldap-2.3.9 from the tree.
 RDEPEND=">=net-nds/openldap-2.4
        dev-python/pyasn1[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
        sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
 DEPEND="${RDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/pyasn1-modules[${PYTHON_USEDEP}] )"
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+       )
+"
 RDEPEND+=" !dev-python/pyldap"
 
 python_prepare_all() {