dev-python/pywavelets: bump & update phases re distutils-r1
authorIan Delaney <idella4@gentoo.org>
Mon, 17 Aug 2015 05:42:34 +0000 (13:42 +0800)
committerIan Delaney <idella4@gentoo.org>
Mon, 17 Aug 2015 05:43:31 +0000 (13:43 +0800)
Package-Manager: portage-2.2.20

dev-python/pywavelets/Manifest
dev-python/pywavelets/pywavelets-0.3.0.ebuild [new file with mode: 0644]

index c9792ae05e9d13385327dc5844363d389ddaa617..ff53073fee17730eaabcce3d10a453ed84a29e82 100644 (file)
@@ -1 +1,2 @@
 DIST PyWavelets-0.2.2.zip 528210 SHA256 04b53436f5f2a9b895a1f56e86e16b94632a5d6bcfc076be1110e41cf3071278 SHA512 2cfd2b0e8f90750cc15ca60400101836f97661e52041abd4c032232eba6843b104c01ef2a50f4384afc5b11dd022add03101ef9b8c1b582ca64e84919f609a5b WHIRLPOOL 07dbec72901deb262a5f52954becee8ff4c9749fa311c206351db86c7612513dec329c6bcbad8e4ab6f1f1043ebfd08cfd8af762df95388789da13dfe6747e2a
+DIST PyWavelets-0.3.0.zip 680099 SHA256 a04bf36ce4ab03b4a4471d598c2097e069d051df3ab3ac01b3f17ba528bf994e SHA512 e197dab2dd6f228f39cf841d3c10c33732fe289ae58bbb969bfd82288aef16fe37cdb283a33e777144e904b7894eae9f06983dbe33fce18d8cb28bd75008ffc4 WHIRLPOOL e6aebf31874d917314e54737d9e3bc226f490e92c0034d34d4dca52ec68985d08b6a107d0efd8487664d54932167406b48f4133f4f6145bc59d1df8aaf29d2ce
diff --git a/dev-python/pywavelets/pywavelets-0.3.0.ebuild b/dev-python/pywavelets/pywavelets-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..ba3107b
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="${PN/pyw/PyW}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for discrete, stationary, and packet wavelet transforms"
+HOMEPAGE="http://www.pybytes.com/pywavelets https://github.com/PyWavelets/pywt"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="
+       app-arch/unzip
+       dev-python/cython[${PYTHON_USEDEP}]
+       test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+       # Taken form tox.ini
+       "${PYTHON}" runtests.py -n -m full pywt/tests/ || die
+}
+
+python_compile() {
+        python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+        distutils-r1_python_compile
+}
+
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       use doc && local HTML_DOCS=( doc/build/html/. )
+       use examples && local   EXAMPLES=( demo/. )
+
+       distutils-r1_python_install_all
+}