dev-ruby/actionpack: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 15 Jul 2018 18:52:33 +0000 (20:52 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 15 Jul 2018 18:57:35 +0000 (20:57 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-ruby/actionpack/Manifest
dev-ruby/actionpack/actionpack-5.0.6.ebuild [deleted file]

index d6c10dd624303456de35e78ca80dde30fcba2ea6..9e79345d7283b390886a357523a9eddcad7ae2b1 100644 (file)
@@ -1,5 +1,4 @@
 DIST rails-4.2.10.tgz 4080905 BLAKE2B 5a46ed9e3664a65545a709577b49864e14cecfc89c798facc0412b4da2842dfb86a611f1fd0ce50da6a40c81a19d3cdce0688b40ad92180ce8ababa5f38d23cc SHA512 c1331638326960c6df9000a2383ad1905d5e794fddddfdc7422cfa2ff89039e3c0e272a79fa43423d5ae0e56436eceb22b8276e6a8bce7eb765da33f02742318
-DIST rails-5.0.6.tgz 6043860 BLAKE2B ae5c1e6df39575a40001ea8b009c39ed414661b1458934efad44e50cb48f3f9906150560008fd3eac39a627c14a32ac3e5f7366b62596d13df11e579beddac6c SHA512 3487db6d59e65a0abe56bf9edfc343a0e0e78119b2bb08f333c8203840ae33897030897d2677d4a28257b479b605b2679ffb7b5d21c724557142023fdb723410
 DIST rails-5.0.7.tgz 6051560 BLAKE2B d5090b2e6c3fb9b7ca460c7439a94d6633ab7bad3cef42ab23851b0127d6b8cf6a34eb3b967c7c9b7ba5bd1d10e483f4c76a60fc06772d567a258b237a449fe6 SHA512 c3f1b882f4679967597c7ecfa3469e8f1dc52f618d26324b292bcd0ed8c854ec93a7570e12cab8becfb9a7ce04bb7e08f9ad353d35f8cfb954bc2144bf093e55
 DIST rails-5.1.4.tgz 6132874 BLAKE2B ec5642b860b7c18cea2c56aa5e2a652e28ab08d39c5863dc4ee66fd3caf375e55706e4317ecae5bfc5581922cf1549c38c22529d2e44a98c84cde332491e49cc SHA512 8f0837e0a2c5b0189375f10310a6e6b43e32f1fecc503582efc6490436c943e774495262e508e4ca1a1874132ae6e4a541e81c06f0d8f6fe8ab85bd2fd10d4fc
 DIST rails-5.1.5.tgz 6142269 BLAKE2B e31b6fb39df4a5cbfa9acd31058b018f5eb8d45d0886d9cb1de5d7de9ed082b67f27d257ac8eeffb0a2663466bc958c72d63309f0a68989d189a11510e835e3e SHA512 8fde1b043976c6bd69235ccbfc1f4ab593fa0cb7ec0dc0cbafcbd2727dfd1b405cc6131e41cc40871bc893cc64f524a347dd91efd1816b724deb5ca1cf879c63
diff --git a/dev-ruby/actionpack/actionpack-5.0.6.ebuild b/dev-ruby/actionpack/actionpack-5.0.6.ebuild
deleted file mode 100644 (file)
index 1bf7699..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-linux"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
-       ~dev-ruby/activesupport-${PV}
-       ~dev-ruby/actionview-${PV}
-       dev-ruby/rack:2.0
-       >=dev-ruby/rack-test-0.6.3:0.6
-       >=dev-ruby/rails-html-sanitizer-1.0.2:1
-       dev-ruby/rails-dom-testing:2
-"
-
-ruby_add_bdepend "
-       test? (
-               dev-ruby/mocha:0.14
-               dev-ruby/bundler
-               ~dev-ruby/railties-${PV}
-               ~dev-ruby/activerecord-${PV}
-               >=dev-ruby/rack-cache-1.2:1.2
-       )"
-
-all_ruby_prepare() {
-       # Remove items from the common Gemfile that we don't need for this
-       # test run. This also requires handling some gemspecs.
-       sed -i -e '1igem "railties", "~>5.0.0"; gem "activerecord", "~>5.0.0"' test/abstract_unit.rb || die
-       sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
-               -e '/:job/,/end/ s:^:#:' \
-               -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
-       rm ../Gemfile.lock || die
-
-       # Skip a failing test related to security updates in 4.2.5.1. Let's
-       # assume that this is not a bug but a test lagging a security
-       # measure.
-       sed -i -e '/test_dynamic_render_with_file/,/^  end/ s:^:#:' \
-               test/controller/render_test.rb || die
-
-       # Skip brittle test depending on mime type registration order (fixed upstream)
-       sed -i -e '/parse application with trailing star/,/^  end/ s:^:#:' \
-               test/dispatch/mime_type_test.rb
-}