net-irc/anope: Fix musl build
authorSam James (sam_c) <sam@cmpct.info>
Tue, 5 May 2020 11:24:22 +0000 (11:24 +0000)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 5 May 2020 13:05:56 +0000 (15:05 +0200)
__USE_GNU_GETTEXT is exposed by musl because they provide
a GNU gettext-compatible interface. This doesn't mean they
provide all the internals that glibc does.

Check for __GLIBC__ if using internal _nl_msg_cat_cntr.

Closes: https://bugs.gentoo.org/716658
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-irc/anope/anope-2.0.7.ebuild
net-irc/anope/files/musl-libintl.patch [new file with mode: 0644]

index 7761a88223aee8ea8d3bd78d2d4add9f57d5300c..02e171b644412a4dff41257de3ff283dc8fbe992 100644 (file)
@@ -35,6 +35,7 @@ RDEPEND="${DEPEND}"
 PATCHES=(
        "${FILESDIR}/pid-patch.patch"
        "${FILESDIR}/example.conf-user.patch"
+       "${FILESDIR}/musl-libintl.patch"
 )
 
 S="${WORKDIR}/${P}-source"
diff --git a/net-irc/anope/files/musl-libintl.patch b/net-irc/anope/files/musl-libintl.patch
new file mode 100644 (file)
index 0000000..f14e494
--- /dev/null
@@ -0,0 +1,22 @@
+diff --git a/src/language.cpp b/src/language.cpp
+index 1915378..c1eeea5 100644
+--- a/src/language.cpp
++++ b/src/language.cpp
+@@ -75,7 +75,7 @@ const char *Language::Translate(const NickCore *nc, const char *string)
+ #if GETTEXT_FOUND
+-#ifdef __USE_GNU_GETTEXT
++#if defined(__GLIBC__)
+ extern "C" int _nl_msg_cat_cntr;
+ #endif
+@@ -87,7 +87,7 @@ const char *Language::Translate(const char *lang, const char *string)
+       if (!lang || !*lang)
+               lang = Config->DefLanguage.c_str();
+-#ifdef __USE_GNU_GETTEXT
++#if defined(__GLIBC__)
+       ++_nl_msg_cat_cntr;
+ #endif