Added 2.6.16 and removed 2.6.13, thanks to toto. Fixes bug #156781
authorTom Knight <tomk@gentoo.org>
Mon, 4 Dec 2006 19:46:14 +0000 (19:46 +0000)
committerTom Knight <tomk@gentoo.org>
Mon, 4 Dec 2006 19:46:14 +0000 (19:46 +0000)
Package-Manager: portage-2.1.1-r1

dev-php/smarty/ChangeLog
dev-php/smarty/files/digest-smarty-2.6.16 [new file with mode: 0644]
dev-php/smarty/smarty-2.6.16.ebuild [new file with mode: 0644]

index ee8de3df6d211d78ed648703ead8f68d4e030957..fd81cf128fcc7ec3f1dd298d77e47e2bcd612963 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-php/smarty
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.65 2006/10/20 21:05:01 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.66 2006/12/04 19:46:14 tomk Exp $
+
+*smarty-2.6.16 (04 Dec 2006)
+
+  04 Dec 2006; Tom Knight <tomk@gentoo.org> -smarty-2.6.13.ebuild,
+  +smarty-2.6.16.ebuild:
+  Added 2.6.16 and removed 2.6.13, thanks to toto. Fixes bug #156781
 
   20 Oct 2006; Bryan Ã˜stergaard <kloeri@gentoo.org> smarty-2.6.14.ebuild:
   Stable on Alpha.
diff --git a/dev-php/smarty/files/digest-smarty-2.6.16 b/dev-php/smarty/files/digest-smarty-2.6.16
new file mode 100644 (file)
index 0000000..5a14cf2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 da67591f19b69a932c1cab7df5b0303a Smarty-2.6.16.tar.gz 151978
+RMD160 d2b66cd9094531fe44c582a37951ea86237defb9 Smarty-2.6.16.tar.gz 151978
+SHA256 1cd3a9c35f47142d685cc1c74129525fe8c54bd92a21023de9c6c120b4374b11 Smarty-2.6.16.tar.gz 151978
diff --git a/dev-php/smarty/smarty-2.6.16.ebuild b/dev-php/smarty/smarty-2.6.16.ebuild
new file mode 100644 (file)
index 0000000..4e4cc2f
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.16.ebuild,v 1.1 2006/12/04 19:46:14 tomk Exp $
+
+inherit php-lib-r1
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://smarty.php.net/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/smarty-docs )"
+
+MY_P="Smarty-${PV}"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+       dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+       php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+       einfo "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+       einfo "To use it in your scripts, either"
+       einfo "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+       einfo "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+       einfo "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+       einfo "cgi-php[45] or cli-php[45])."
+       echo
+       einfo "If you're upgrading from a previous version make sure to clear out your"
+       einfo "templates_c and cache directories as some include paths have changed!"
+       echo
+       einfo "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
+       einfo "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
+       einfo "include_path accordingly."
+}