dev-python/twine-3.1.1: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 5 Dec 2019 00:19:19 +0000 (16:19 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 5 Dec 2019 00:20:58 +0000 (16:20 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/twine/Manifest
dev-python/twine/twine-3.1.1.ebuild [new file with mode: 0644]

index 56ff54b86cd6d282f034ea3fee05933f211adf05..5572fee5f2939c79b7a1873f35fb92d106aa9127 100644 (file)
@@ -1,3 +1,4 @@
 DIST twine-1.11.0.tar.gz 55301 BLAKE2B 88e88bc88a6dc8320064b3e296d85f1614d1ecf1628c8442737566ac58c3296b2292f147c0b39047a1d13a3ac98297fd7a77a0ba6fdb6ff04e59d16bc8ed463a SHA512 28e588f26b59bc9f4a8481caf2353934ad6927734762ffebb4416c147ec9e6dffb37092def20a76eb888c94b27f97e013dacc42c63e5dcda30f4290bb6c90a22
 DIST twine-1.15.0.tar.gz 135851 BLAKE2B 5e85c30e23615e9fa7e40ed767412560b29c42ec777afbb17850781a384bc2d3787534a8114a65ac2374ab80441eb2d3b6d75dcff400e7b47a42453a9210130d SHA512 e0eae05c108e1e766a0a8ec684e3423b0537c8aa671675f30403171fd4f48ec65666d407df53f6dd9eefa0b98e5fd2fdf7dbf1f0f9150686c499de131f6f2435
 DIST twine-3.0.0.tar.gz 138502 BLAKE2B 80cc475704979030435505103e45cfd051d2e3979e6fd9d4ad33fdbb2644bdebf789c504491f22a161f346295222287114ab68034560360f08a1beadefb20ac0 SHA512 1f5577c74c47618ae07672b53633110a5ecb486d25046cb87f36cbf5974b679714f962803b9dc6e970c57d8f2542b323e11437e76effe7172511557b56df5f12
+DIST twine-3.1.1.tar.gz 138692 BLAKE2B d96e207b5ef1314f547f5e8fbf36565d5cf29f0dd19438d41fcbb154a98b854c669740b533a28cd79501933f0cef57767e63a83f135fcdbc196df8865cfc4d8a SHA512 446b36a1816db6131e279bda26e62c58f9659d86178d498ebb9f7c5287b61cf969e625debe4b4cb1e32832e0eecbcedcf4913319ae0bf7eb287f56e550d33ed9
diff --git a/dev-python/twine/twine-3.1.1.ebuild b/dev-python/twine/twine-3.1.1.ebuild
new file mode 100644 (file)
index 0000000..7c6580a
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${CDEPEND}
+       test? (
+               dev-python/jaraco-envs[${PYTHON_USEDEP}]
+               dev-python/jaraco-functools[${PYTHON_USEDEP}]
+               dev-python/munch[${PYTHON_USEDEP}]
+               dev-python/portend[${PYTHON_USEDEP}]
+               dev-python/pretend[${PYTHON_USEDEP}]
+               dev-python/pypiserver[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}
+       >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+       >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+       >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{6,7} pypy{,3})
+       >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+       "${FILESDIR}/twine-3.0.0-tests.patch"
+)
+
+python_prepare_all() {
+       # avoid a setuptools_scm dependency
+       sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+       sed -r -i "s:setuptools(_|-)scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
+               setup.cfg || die
+
+       # requires internet
+       rm -f tests/test_integration.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}