net-misc/wget2: Initial commit
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 8 Mar 2020 21:02:26 +0000 (22:02 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 8 Mar 2020 21:02:49 +0000 (22:02 +0100)
Closes: https://bugs.gentoo.org/693638
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/wget2/Manifest [new file with mode: 0644]
net-misc/wget2/files/wget2-1.99.2-remove_ldconfig_call.patch [new file with mode: 0644]
net-misc/wget2/metadata.xml [new file with mode: 0644]
net-misc/wget2/wget2-1.99.2.ebuild [new file with mode: 0644]

diff --git a/net-misc/wget2/Manifest b/net-misc/wget2/Manifest
new file mode 100644 (file)
index 0000000..75fd632
--- /dev/null
@@ -0,0 +1 @@
+DIST wget2-1.99.2.tar.gz 3173906 BLAKE2B 1fc63de32725d0d980469cc730d17035a01ccb432a91fe24c37e06017c2604a4ef6d8474e76eb757c3a22cc61ea6c70e26af40dffc474a87f8bbdb2a8deced7c SHA512 c2c687124a2463d6a0397cd7dbbc5e475ba815e8d7e13a4b71b529e6be03c9f7dbe5f358702e929ed36034f6fffc698f3b1c5ac486a35e2b00ee6f135060ad7f
diff --git a/net-misc/wget2/files/wget2-1.99.2-remove_ldconfig_call.patch b/net-misc/wget2/files/wget2-1.99.2-remove_ldconfig_call.patch
new file mode 100644 (file)
index 0000000..6953b73
--- /dev/null
@@ -0,0 +1,25 @@
+From eb2aefb01868e91f2e1252ddd1bcdb9c075e5b49 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Sun, 8 Mar 2020 21:46:15 +0100
+Subject: [PATCH] Don't run ldconfig by default
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ Makefile.am | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 979ad1b1..5bc6f6ce 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -75,7 +75,3 @@ fuzz-coverage: clean clean-lcov
+ check-local:
+       $(AM_V_at)$(MAKE) -s syntax-check >/dev/null
+       $(AM_V_at)$(srcdir)/contrib/check_options $(srcdir)/docs/wget2.md $(builddir)/src/wget2$(EXEEXT)
+-
+-# ppl often forget to run ldconfig after an install, so let's do it here
+-install-exec-hook:
+-      $(AM_V_at)$(LDCONFIG) || :
+-- 
+2.25.1
+
diff --git a/net-misc/wget2/metadata.xml b/net-misc/wget2/metadata.xml
new file mode 100644 (file)
index 0000000..c84bc2d
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>polynomial-c@gentoo.org</email>
+               <name>Lars Wendler</name>
+       </maintainer>
+       <use>
+               <flag name="brotli">Enable support for brotli compression</flag>
+               <flag name="gpgme">Build gpgme backend</flag>
+               <flag name="http2">Enable HTTP/2.0 support</flag>
+               <flag name="openssl">Enable crypto support via dev-libs/openssl</flag>
+               <flag name="psl">Use public suffix list via media-libs/libnspsl</flag>
+               <flag name="valgrind">Depend on dev-util/vagrind for test suite</flag>
+       </use>
+</pkgmetadata>
diff --git a/net-misc/wget2/wget2-1.99.2.ebuild b/net-misc/wget2/wget2-1.99.2.ebuild
new file mode 100644 (file)
index 0000000..67a2db4
--- /dev/null
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
+HOMEPAGE="https://gitlab.com/gnuwget/wget2"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/0" # subslot = libwget.so version
+KEYWORDS="~amd64 ~x86"
+
+IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn libressl lzma openssl pcre psl +ssl test valgrind xattr zlib"
+
+REQUIRED_USE="valgrind? ( test )"
+
+RDEPEND="
+       brotli? ( app-arch/brotli )
+       bzip2? ( app-arch/bzip2 )
+       !gnutls? ( dev-libs/libgcrypt:= )
+       ssl? (
+               gnutls? ( net-libs/gnutls )
+               !gnutls? (
+                       libressl? ( dev-libs/libressl:0= )
+                       !libressl? ( dev-libs/openssl:0= )
+               )
+       )
+       gpgme? (
+               app-crypt/gpgme
+               dev-libs/libassuan
+               dev-libs/libgpg-error
+       )
+       http2? ( net-libs/nghttp2 )
+       idn? ( net-dns/libidn2:= )
+       lzma? ( app-arch/xz-utils )
+       pcre? ( dev-libs/libpcre2 )
+       psl? ( net-libs/libpsl )
+       xattr? ( sys-apps/attr )
+       zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+       valgrind? ( dev-util/valgrind )
+"
+
+PATCHES=(
+       # Upstream attempts to be "smart" by calling ldconfig in
+       # install-exec-hook
+       "${FILESDIR}"/${PN}-1.99.2-remove_ldconfig_call.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --with-plugin-support
+               --with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
+               --without-libidn
+               --without-libmicrohttpd
+               $(use_enable doc)
+               $(use_enable valgrind valgrind-tests)
+               $(use_enable xattr)
+               $(use_with brotli brotlidec)
+               $(use_with bzip2)
+               $(use_with gpgme)
+               $(use_with http2 libnghttp2)
+               $(use_with idn libidn2)
+               $(use_with lzma)
+               $(use_with pcre libpcre2)
+               $(use_with psl libpsl)
+               $(use_with zlib)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       doman docs/man/man{1/*.1,3/*.3}
+
+       find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+       rm "${ED}"/usr/bin/${PN}_noinstall || die
+}