sys-boot/tboot: Fix breakage triggered by mount-boot update.
authorUlrich Müller <ulm@gentoo.org>
Fri, 13 Dec 2019 22:32:08 +0000 (23:32 +0100)
committerUlrich Müller <ulm@gentoo.org>
Fri, 13 Dec 2019 22:33:45 +0000 (23:33 +0100)
mount-boot_mount_boot_partition() was an internal and undocumented
function which shouldn't have been called, in the first place.

Delete it from pkg_postinst without replacement, because the relevant
checks in mount-boot_check_status will have been called already in
mount-boot_pkg_preinst.

Drop the call to mount-boot_pkg_postinst as well, because that
function is a no-op now.

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
sys-boot/tboot/tboot-1.9.6_p20171118.ebuild

index e33aa1ee7e935fc293e37a94ebcf44f44a8e01cf..1b591eb5a46fd5bb699071bac82aa0c4dae2fd6c 100644 (file)
@@ -59,12 +59,8 @@ src_install() {
 }
 
 pkg_postinst() {
-       mount-boot_mount_boot_partition
-
        cp ${ROOT%/}/usr/lib/tboot/boot/* ${ROOT%/}/boot/
 
-       mount-boot_pkg_postinst
-
        ewarn "Please remember to download the SINIT AC Module relevant"
        ewarn "for your platform from:"
        ewarn "http://software.intel.com/en-us/articles/intel-trusted-execution-technology/"