x11-misc/x2vnc: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 19:42:58 +0000 (20:42 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 19:50:42 +0000 (20:50 +0100)
Closes: https://bugs.gentoo.org/697150
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-misc/x2vnc/files/expectk.patch
x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild

index 5c5ba6887cb1f6ef87b35ac10795db3e9620bfd7..354dc4ffbe9e7b7d948ad774c7874161236189c1 100644 (file)
@@ -1,5 +1,5 @@
---- tkx2vnc    2010-03-14 21:31:49.000000000 +0100
-+++ tkx2vnc.new        2010-03-14 21:32:58.000000000 +0100
+--- a/contrib/tkx2vnc  2010-03-14 21:31:49.000000000 +0100
++++ b/contrib/tkx2vnc  2010-03-14 21:32:58.000000000 +0100
 @@ -1,10 +1,13 @@
 -#!/usr/bin/expectk -f
 +#!/usr/bin/wish
index 7a41c7b368d70e58c4aa3305d3848795a56fbca8..31f6fe487ba80409624255c0fa58360d05b64004 100644 (file)
@@ -1,15 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Control a remote computer running VNC from X"
 HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
 SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="alpha amd64 ppc sparc x86"
 IUSE="tk"
@@ -22,15 +20,13 @@ DEPEND="${RDEPEND}
        x11-base/xorg-proto
        tk? ( dev-tcltk/expect )"
 
-src_unpack() {
-               unpack ${A}
-               cd "${S}/contrib"
-               epatch "${FILESDIR}/expectk.patch"
-}
+PATCHES=(
+       "${FILESDIR}/expectk.patch"
+)
 
 src_install() {
        dodir /usr/share /usr/bin
-       make DESTDIR="${D}" install || die
+       emake DESTDIR="${D}" install
        use tk && dobin contrib/tkx2vnc
        dodoc ChangeLog README
 }