app-emulation/libvirt: add a libvirt group, bug #597772
authorMatthias Maier <tamiko@gentoo.org>
Sun, 22 Jan 2017 16:14:10 +0000 (10:14 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 22 Jan 2017 16:28:26 +0000 (10:28 -0600)
Add a libvirt group for convenience and update readme

Package-Manager: Portage-2.3.0, Repoman-2.3.1

app-emulation/libvirt/files/README.gentoo-r2 [new file with mode: 0644]
app-emulation/libvirt/libvirt-2.5.0-r2.ebuild
app-emulation/libvirt/libvirt-9999.ebuild

diff --git a/app-emulation/libvirt/files/README.gentoo-r2 b/app-emulation/libvirt/files/README.gentoo-r2
new file mode 100644 (file)
index 0000000..1c086c1
--- /dev/null
@@ -0,0 +1,58 @@
+Important: The openrc libvirtd init script is now broken up into two
+separate services: libvirtd, that solely handles the daemon, and
+libvirt-guests, that takes care of clients during shutdown/restart of the
+host. In order to reenable client handling, edit /etc/conf.d/libvirt-guests
+and enable the service and start it:
+
+       $ rc-update add libvirt-guests
+       $ service libvirt-guests start
+
+
+For the basic networking support (bridged and routed networks) you don't
+need any extra software. For more complex network modes including but not
+limited to NATed network, you can enable the 'virt-network' USE flag. It
+will pull in required runtime dependencies
+
+
+If you are using dnsmasq on your system, you will have to configure
+/etc/dnsmasq.conf to enable the following settings:
+
+       bind-interfaces
+       interface or except-interface
+
+Otherwise you might have issues with your existing DNS server.
+
+
+For openrc users:
+
+       Please use /etc/conf.d/libvirtd to control the '--listen' parameter for
+       libvirtd.
+
+       Use /etc/init.d/libvirt-guests to manage clients on restart/shutdown of
+       the host. The default configuration will suspend and resume running kvm
+       guests with 'managedsave'. This behavior can be changed under
+       /etc/conf.d/libvirt-guests
+
+
+For systemd users:
+
+       Please use /etc/systemd/system/libvirtd.service.d/00gentoo.conf
+       to control the '--listen' parameter for libvirtd.
+
+       The configuration for the 'libvirt-guests.service' is found under
+       /etc/libvirt/libvirt-guests.conf"
+
+
+If you have built libvirt with policykit support, a new group "libvirt" has
+been created. Simply add a user to the libvirt group in order to grant
+administrative access to libvirtd. Alternatively, drop a custom policykit
+rule into /etc/polkit-1/rules.d.
+
+If you have built libvirt without policykit support (USE=-policykit), you
+must change the unix sock group and/or perms in /etc/libvirt/libvirtd.conf
+in order to allow normal users to connect to libvirtd.
+
+
+If libvirtd is built with USE=caps, libvirt will now start qemu/kvm VMs
+with non-root privileges. Ensure any resources your VMs use are accessible
+by qemu:qemu.
index 9f9134680d1951bd85517d6d391bab87836dbeb8..a40c305d09271e98d725f8b748455e9de02afa64 100644 (file)
@@ -135,6 +135,8 @@ pkg_setup() {
                enewuser qemu 77 -1 -1 "qemu,kvm"
        fi
 
+       use policykit && enewgroup libvirt
+
        # Check kernel configuration:
        CONFIG_CHECK=""
        use fuse && CONFIG_CHECK+="
@@ -356,7 +358,7 @@ src_install() {
        newconfd "${FILESDIR}/libvirtd.confd-r5" libvirtd || die
        newconfd "${FILESDIR}/libvirt-guests.confd" libvirt-guests || die
 
-       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r1")
+       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r2")
        DISABLE_AUTOFORMATTING=true
        readme.gentoo_create_doc
 }
@@ -376,7 +378,9 @@ pkg_postinst() {
        use libvirtd || return 0
        # From here, only libvirtd-related instructions, be warned!
 
-       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r1")
+
+       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r2")
        DISABLE_AUTOFORMATTING=true
+       FORCE_PRINT_ELOG=1 # remove for next version bump
        readme.gentoo_print_elog
 }
index 81795e4a7f6bf4bb7e70685b3bd425130e10587c..1fcac6e2f214b858f526e9d486d63b7c8d6019f6 100644 (file)
@@ -135,6 +135,8 @@ pkg_setup() {
                enewuser qemu 77 -1 -1 "qemu,kvm"
        fi
 
+       use policykit && enewgroup libvirt
+
        # Check kernel configuration:
        CONFIG_CHECK=""
        use fuse && CONFIG_CHECK+="
@@ -356,7 +358,7 @@ src_install() {
        newconfd "${FILESDIR}/libvirtd.confd-r5" libvirtd || die
        newconfd "${FILESDIR}/libvirt-guests.confd" libvirt-guests || die
 
-       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r1")
+       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r2")
        DISABLE_AUTOFORMATTING=true
        readme.gentoo_create_doc
 }
@@ -376,7 +378,8 @@ pkg_postinst() {
        use libvirtd || return 0
        # From here, only libvirtd-related instructions, be warned!
 
-       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r1")
+       DOC_CONTENTS=$(<"${FILESDIR}/README.gentoo-r2")
        DISABLE_AUTOFORMATTING=true
+       FORCE_PRINT_ELOG=1 # remove for next version bump
        readme.gentoo_print_elog
 }