x11-wm/muffin: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Nov 2015 21:11:34 +0000 (22:11 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Nov 2015 22:29:36 +0000 (23:29 +0100)
Package-Manager: portage-2.2.24

x11-wm/muffin/Manifest
x11-wm/muffin/muffin-2.8.0.ebuild [new file with mode: 0644]

index 17643af2e7c2f5dec140ca3068c2b401b835f24d..4697f84efb04b885df88577c60ab97ee78ba27ab 100644 (file)
@@ -1,3 +1,4 @@
 DIST muffin-2.4.4.tar.gz 2706446 SHA256 027641f3bc12a5770f063ffbf9ff0a4797768d256449941ae0be779700b90805 SHA512 57321f73af81dd9e03ec81b56fec83a5a154f06fcfe113a8129aaa279f0e11bed446efe98693aa52f7d490b4ddc73ba76db237d75dfff7b670427b3c8fc8abff WHIRLPOOL 7c9ae74c3053b2d2eed876d63e509d02ff693fdd88aedf4ab835a7bf5105a098c1ca99ec36e35d2d24ae352a7caeaa661693e1532a30e14cb4044c2b6821dd58
 DIST muffin-2.4.5.tar.gz 2706742 SHA256 b38d62cb0d4ec9e213cc41501bda0d4712eebab7cd4fbc5ca0bdf8b5e74f83f7 SHA512 f8a791d88823197f8b727e00cd67e22adabbdf6fbad3a1ebd1a75087a48e09ad4c39b9b5550303db661c54937f5f42e25c2ac47ccdd98d281b4ff9aad5f5d71f WHIRLPOOL 6d9ff8ee2a09040baa8930006a4e48a6ab6ee7082a56a30826b1f57e6a317aa942a3dc1d4aafe993ce54209fb8e20bf0cb759a9fe2a4547afaa3d870ce0da72f
 DIST muffin-2.6.1.tar.gz 2702177 SHA256 0772ad6caace2f4570e7d3a0cbc8a6ef5f65be92c6a30cc95a59ed8bba6b5f74 SHA512 530e4bdabb780a16ddad237ab7aa1c2dbb688f6d1380dd0d18fa91b62675d36a2253415899d59957b7f34291c348b8a0e1a99214c3151c2fc2bc1d90f068d788 WHIRLPOOL d6832ac81051845432b21f66ff74499213f57dc66bea7d61f0a30c3a0aec54846911447451b8b54ccb0678ed00dfad90ce9cef9b2f2492d44e7c35adad2c5a24
+DIST muffin-2.8.0.tar.gz 2713841 SHA256 c3922730da0c756e0983fcb17a9cee8258fbc6894ec074248745a89f0f4c8623 SHA512 dfe716560aa83678fec0053cc596c9e08d0d0c2c090bed94fd097bb8f9569dc54c799d99240fe74ba09ad04f89ad0ce5e475499de94b13809c919cf5ca80a096 WHIRLPOOL b130f25e3554a9f6fd9b434087008c6cdd142df0d22399bd9209730ecfafb2d8a3b3c00bac0ef91b7313762e1c48a1171bb5d8218b3cb8d7430f97568499d0f1
diff --git a/x11-wm/muffin/muffin-2.8.0.ebuild b/x11-wm/muffin/muffin-2.8.0.ebuild
new file mode 100644 (file)
index 0000000..01f7091
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-any-r1
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+       >=x11-libs/pango-1.2[X,introspection?]
+       >=x11-libs/cairo-1.14:=[X]
+       x11-libs/gdk-pixbuf:2[introspection?]
+       >=x11-libs/gtk+-3.9.12:3[X,introspection?]
+       >=dev-libs/glib-2.37.3:2[dbus]
+       >=gnome-extra/cinnamon-desktop-2.4:0=[introspection?]
+       >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+       >=media-libs/clutter-1.14.3:1.0=[introspection?]
+       >=media-libs/cogl-1.13.3:1.0=[introspection?]
+       >=media-libs/libcanberra-0.26[gtk3]
+       >=x11-libs/libXcomposite-0.3
+       >=x11-libs/startup-notification-0.7:=
+
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libX11
+       x11-libs/libXcomposite
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       virtual/opengl
+
+       gnome-extra/zenity
+
+       introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+       xinerama? ( x11-libs/libXinerama )
+"
+# needs gtk-doc, not just -am, for gtk-doc.make
+DEPEND="${COMMON_DEPEND}
+       ${PYTHON_DEPS}
+       >=app-text/gnome-doc-utils-0.8
+       sys-devel/gettext
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=dev-util/intltool-0.35
+       virtual/pkgconfig
+       test? ( app-text/docbook-xml-dtd:4.5 )
+       xinerama? ( x11-proto/xineramaproto )
+       x11-proto/xextproto
+       x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+       !x11-misc/expocity
+"
+
+src_prepare() {
+       epatch_user
+       eautoreconf
+       gnome2_src_prepare
+}
+
+src_configure() {
+       DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+       gnome2_src_configure \
+               --disable-static \
+               --enable-shape \
+               --enable-sm \
+               --enable-startup-notification \
+               --enable-xsync \
+               --enable-verbose-mode \
+               --with-libcanberra \
+               $(use_enable introspection) \
+               $(use_enable xinerama)
+}