app-vim/nerdtree: add live ebuild
authorTim Harder <radhermit@gentoo.org>
Thu, 17 Aug 2017 20:45:20 +0000 (16:45 -0400)
committerTim Harder <radhermit@gentoo.org>
Thu, 17 Aug 2017 20:45:20 +0000 (16:45 -0400)
app-vim/nerdtree/nerdtree-9999.ebuild [new file with mode: 0644]

diff --git a/app-vim/nerdtree/nerdtree-9999.ebuild b/app-vim/nerdtree/nerdtree-9999.ebuild
new file mode 100644 (file)
index 0000000..54290f4
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/scrooloose/nerdtree.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: A tree explorer plugin for navigating the filesystem"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1658 https://github.com/scrooloose/nerdtree"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="NERD_tree"
+
+src_prepare() {
+       rm LICENCE screenshot.png || die
+       default
+}