dev-lang/jsonnet: Version bump to 0.14.0
authorPatrick McLean <patrick.mclean@sony.com>
Mon, 16 Sep 2019 20:45:15 +0000 (13:45 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 16 Sep 2019 20:45:15 +0000 (13:45 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-lang/jsonnet/Manifest
dev-lang/jsonnet/files/jsonnet-0.14.0-makefile.patch [new file with mode: 0644]
dev-lang/jsonnet/jsonnet-0.14.0.ebuild [new file with mode: 0644]
dev-lang/jsonnet/metadata.xml

index dc57a4ec785d5c2cec1f768d516c3270d984a4cd..16e59487bbd775bbc00d16efeeb7f50b5f51076f 100644 (file)
@@ -1,2 +1,3 @@
 DIST jsonnet-0.12.1.tar.gz 21839349 BLAKE2B 8601a35263003723b435d0075fe60f5301a49bddf63cdd55958df3eb7474569c28dbf54e0ba9d07fb6ade395af725193d1432b2c43fb2b271531af179e850df4 SHA512 25523dd19b4209a5ca39275ab3d3726b934442dd83a965ab0b79f0c67bd8ae85c438b2a63990b8eec921b137f908f946696be331b08cef92f15b6b8fa548cb0d
 DIST jsonnet-0.13.0.tar.gz 21850449 BLAKE2B fa0665d63b09dfc01a7454268d6edd467524cdfdb5d53e838665f046f1f08608c493503a88d7af7e26c3dc07e0ae4323753affab90c5ac41c27ebe8b7b39a4a0 SHA512 d19e5398763e37b79b0ef02368f6bd6215d2df234b5ff7a6d98e2306a0d47290600061c9f868c0c262570b4f0ee9eee6c309bcc93937b12f6c14f8d12339a7d5
+DIST jsonnet-0.14.0.tar.gz 21857157 BLAKE2B 93de74fa07efa300097ccb9503b41543beb749d5aff130ad9a6139a3ceb0a07b404aa50877d4cbacd9eb26b2194d8cd9bf578521f17f84a3480655b179525663 SHA512 e09fb27202a34e88134d98d59fdccd4f1ee777e7c8090c3687cb5c11b9ada3bfe7b878322e0274743694ff77457215484470ccf90d03d9d36159288e5a18ab0b
diff --git a/dev-lang/jsonnet/files/jsonnet-0.14.0-makefile.patch b/dev-lang/jsonnet/files/jsonnet-0.14.0-makefile.patch
new file mode 100644 (file)
index 0000000..a6107a4
--- /dev/null
@@ -0,0 +1,16 @@
+diff --git a/Makefile b/Makefile
+index 474655c..89c396c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -31,9 +31,9 @@ OPT ?= -O3
+ PREFIX ?= /usr/local
+-CXXFLAGS ?= -g $(OPT) -Wall -Wextra -Woverloaded-virtual -pedantic -std=c++0x -fPIC
++CXXFLAGS += -Wall -Wextra -Woverloaded-virtual -pedantic -std=c++0x -fPIC
+ CXXFLAGS += -Iinclude -Ithird_party/md5 -Ithird_party/json
+-CFLAGS ?= -g $(OPT) -Wall -Wextra -pedantic -std=c99 -fPIC
++CFLAGS += -Wall -Wextra -pedantic -std=c99 -fPIC
+ CFLAGS += -Iinclude
+ MAKEDEPENDFLAGS += -Iinclude -Ithird_party/md5 -Ithird_party/json
+ EMCXXFLAGS = $(CXXFLAGS) -g0 -Os --memory-init-file 0 -s DISABLE_EXCEPTION_CATCHING=0 -s OUTLINING_LIMIT=10000 -s RESERVED_FUNCTION_POINTERS=20 -s ASSERTIONS=1 -s ALLOW_MEMORY_GROWTH=1
diff --git a/dev-lang/jsonnet/jsonnet-0.14.0.ebuild b/dev-lang/jsonnet/jsonnet-0.14.0.ebuild
new file mode 100644 (file)
index 0000000..6c941fa
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit toolchain-funcs flag-o-matic distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="custom-optimization python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+BDEPEND="python? ( ${PYTHON_DEPS}
+               dev-python/setuptools[${PYTHON_USEDEP}]
+       )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+       "${FILESDIR}/jsonnet-0.14.0-makefile.patch"
+       "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+)
+
+src_prepare() {
+       default
+       use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+       use custom-optimization || replace-flags '-O*' -O3
+       default
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+               jsonnet \
+               libjsonnet.so \
+               libjsonnet++.so
+
+       use python && distutils-r1_src_compile
+}
+
+src_test() {
+       emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
+       use python && distutils-r1_src_test
+}
+
+python_test() {
+       esetup.py test || die
+}
+
+src_install() {
+       dolib.so libjsonnet*.so
+       dobin jsonnet
+
+       use python && distutils-r1_src_install
+}
index 9c2644baf918e50c49d8c346971cc7d2dcf8b3ca..6a3ebc349696d83cf3c88d7828c46f385ac5dda6 100644 (file)
@@ -12,4 +12,8 @@
   <upstream>
     <remote-id type="github">google/jsonnet</remote-id>
   </upstream>
+  <use>
+    <flag name="custom-optimization">Build with user-specified compiler optimizations
+      (-Os, -O0, -O1, -O2, -O3) from CFLAGS (unsupported)</flag>
+  </use>
 </pkgmetadata>