net-analyzer/nagios-core: new version 4.4.4.
authorMichael Orlitzky <mjo@gentoo.org>
Wed, 14 Aug 2019 23:45:56 +0000 (19:45 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Thu, 15 Aug 2019 00:04:50 +0000 (20:04 -0400)
Bug: https://bugs.gentoo.org/692092
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
net-analyzer/nagios-core/Manifest
net-analyzer/nagios-core/nagios-core-4.4.4.ebuild [new file with mode: 0644]

index 0b68556092708162db9c4da7d389d55a2e0495c6..a794553e346f7b47cbbe50acf55a557f8fa503bf 100644 (file)
@@ -1,3 +1,4 @@
 DIST nagios-4.3.4.tar.gz 11101966 BLAKE2B 6cb8182f40a4f83875c94df040bb1c62ce078d4130e10fa8595ea0b14cf715fc2a237ffb34199da9c1528e4789f3ce8deae3d993b5b795ad712d48b1e5fdb820 SHA512 f4e92aa98151739442a225a245871d93b5560d89510bdacb1a615959b9687f7a92675f10fcba71078b104ca8f237b0155a9261d67ec66f80aec7f033b4b3e316
 DIST nagios-4.4.3.tar.gz 11302228 BLAKE2B d22ab64268832897dfa67d805a5d74656f7aa96ce1427c7326b632060d8c1ea0fbd07564f3c7a978bb5e2c0cba0c06290e7b0d579017fe73b900eb290c7853ae SHA512 07c91a796d634ffda73305edb54e01e46cb4fc9dc996c937e657c18f8067d7e2d31421b058a04b7395ef739962445ea149c486caaac94b7d422b4032bdaa07d4
+DIST nagios-4.4.4.tar.gz 11303598 BLAKE2B e4015ca5c0383b0540f2eaf3d608343df850c6045a4539c1f1ab8c19dc95e9223816efe71034b37f6995cb623dc6b83c92e22a677fe687a34d2215b1a2758c90 SHA512 c8f2b83bad744d67be4ba8356d9eea0be3efbf42d9a215d64815cdf7d944eba798348ce0faea6cebe64f1c99e0edbf12540d83ca42f8b4b563cbcc60139afdb0
 DIST nagios-core-gentoo-icons-20141125.tar 40960 BLAKE2B 31c1953e1160c7c7b89606b72b1a80407e4c1b7a7938b40bd1c577cd0c309dd88ca6b775d692a9b846dbf67736537fa9c91e56aa15fdd447769608ca525bff09 SHA512 bf109879cddd6136b76baba55d0b60b2596e37431dcf5ce0905d34a9fa292ebf7e4bde82d9a084362c486e8fac344c76d88f9298b1b85541ed70ffd608493766
diff --git a/net-analyzer/nagios-core/nagios-core-4.4.4.ebuild b/net-analyzer/nagios-core/nagios-core-4.4.4.ebuild
new file mode 100644 (file)
index 0000000..74ddb85
--- /dev/null
@@ -0,0 +1,213 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs user
+
+MY_P=${PN/-core}-${PV}
+DESCRIPTION="Nagios core - monitoring daemon, web GUI, and documentation"
+HOMEPAGE="https://www.nagios.org/"
+
+# The name of the directory into which our Gentoo icons will be
+# extracted, and also the basename of the archive containing it.
+GENTOO_ICONS="${PN}-gentoo-icons-20141125"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz
+       web? ( https://dev.gentoo.org/~mjo/distfiles/${GENTOO_ICONS}.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="apache2 classicui lighttpd perl +web vim-syntax"
+
+# In pkg_postinst(), we change the group of the Nagios configuration
+# directory to that of the web server user. It can't belong to both
+# apache/lighttpd groups at the same time, so we block this combination
+# for our own sanity.
+#
+# This could be made to work, but we would need a better way to allow
+# the web user read-only access to Nagios's configuration directory.
+#
+REQUIRED_USE="apache2? ( !lighttpd )"
+
+#
+# Note, we require one of the apache2 CGI modules:
+#
+#   * mod_cgi
+#   * mod_cgid
+#   * mod_fcgid
+#
+# We just don't care /which/ one. And of course PHP supports both CGI
+# (USE=cgi) and FastCGI (USE=fpm). We're pretty lenient with the
+# dependencies, and expect the user not to do anything /too/
+# stupid. (For example, installing Apache with only FastCGI support, and
+# PHP with only CGI support.)
+#
+# Another annoyance is that the upstream Makefile uses app-arch/unzip to
+# extract a snapshot of AngularJS, but that's only needed when USE=web.
+#
+MOD_ALIAS=apache2_modules_alias
+DEPEND="dev-libs/libltdl:0
+       virtual/mailx
+       perl? ( dev-lang/perl:= )
+       web? (
+               app-arch/unzip
+               media-libs/gd[jpeg,png]
+               lighttpd? ( www-servers/lighttpd[php] )
+               apache2? (
+                       || (
+                               >=www-servers/apache-2.4[${MOD_ALIAS},apache2_modules_cgi]
+                               >=www-servers/apache-2.4[${MOD_ALIAS},apache2_modules_cgid]
+                               >=www-servers/apache-2.4[${MOD_ALIAS},apache2_modules_fcgid] )
+                       || (
+                               dev-lang/php:*[apache2]
+                               dev-lang/php:*[cgi]
+                               dev-lang/php:*[fpm] )
+               )
+       )"
+RDEPEND="${DEPEND}
+       vim-syntax? ( app-vim/nagios-syntax )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       enewgroup nagios
+       enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_configure() {
+       local myconf
+
+       if use perl; then
+               myconf="${myconf} --enable-embedded-perl --with-perlcache"
+       fi
+
+       if use !apache2 && use !lighttpd ; then
+               myconf="${myconf} --with-command-group=nagios"
+       else
+               if use apache2 ; then
+                       myconf="${myconf} --with-command-group=apache"
+                       myconf="${myconf} --with-httpd-conf=/etc/apache2/conf.d"
+               elif use lighttpd ; then
+                       myconf="${myconf} --with-command-group=lighttpd"
+               fi
+       fi
+
+       econf ${myconf} \
+               --prefix=/usr \
+               --bindir=/usr/sbin \
+               --localstatedir=/var/nagios \
+               --sysconfdir=/etc/nagios \
+               --libexecdir=/usr/$(get_libdir)/nagios/plugins \
+               --with-cgibindir=/usr/$(get_libdir)/nagios/cgi-bin \
+               --with-webdir=/usr/share/nagios/htdocs
+}
+
+src_compile() {
+       emake CC=$(tc-getCC) nagios
+
+       if use web; then
+               # Only compile the CGIs/HTML when USE=web is set.
+               emake CC=$(tc-getCC) DESTDIR="${D}" cgis html
+       fi
+}
+
+src_install() {
+       dodoc Changelog CONTRIBUTING.md README.md THANKS UPGRADING
+
+       # There is no way to install the CGIs unstripped from the top-level
+       # makefile, so descend into base/ here. The empty INSTALL_OPTS
+       # ensures that root:root: owns the nagios executables.
+       cd "${S}/base" || die
+       emake INSTALL_OPTS="" DESTDIR="${D}" install-unstripped
+       cd "${S}" || die
+
+       # Otherwise this gets installed as 770 and you get "access denied"
+       # for some reason or other when starting nagios. The permissions
+       # on nagiostats are just for consistency (these should both get
+       # fixed upstream).
+       fperms 775 /usr/sbin/nagios /usr/sbin/nagiostats
+
+       # INSTALL_OPTS are needed for most of install-basic, but we don't
+       # want them on the LIBEXECDIR, argh.
+       emake DESTDIR="${D}" install-basic
+       fowners root:root /usr/$(get_libdir)/nagios/plugins
+
+       # Don't make the configuration owned by the nagios user, because
+       # then he can edit nagios.cfg and trick nagios into running as root
+       # and doing his bidding.
+       emake INSTALL_OPTS="" DESTDIR="${D}" install-config
+
+       # No INSTALL_OPTS used in install-commandmode, thankfully.
+       emake DESTDIR="${D}" install-commandmode
+
+       if use web; then
+               # There is no way to install the CGIs unstripped from the
+               # top-level makefile, so descend into cgi/ here. The empty
+               # INSTALL_OPTS ensures that root:root: owns the CGI executables.
+               cd "${S}/cgi" || die
+               emake INSTALL_OPTS="" DESTDIR="${D}" install-unstripped
+               cd "${S}" || die
+
+               # install-html installs the new exfoliation theme
+               emake INSTALL_OPTS="" DESTDIR="${D}" install-html
+
+               if use classicui; then
+                       # This overwrites the already-installed exfoliation theme
+                       emake INSTALL_OPTS="" DESTDIR="${D}" install-classicui
+               fi
+
+               # Install cute Gentoo icons (bug #388323), setting their
+               # owner, group, and mode to match those of the rest of Nagios's
+               # images.
+               insinto /usr/share/nagios/htdocs/images/logos
+               doins "${WORKDIR}/${GENTOO_ICONS}"/*.*
+       fi
+
+       newinitd startup/openrc-init nagios
+
+       if use web ; then
+               if use apache2 ; then
+                       # Install the Nagios configuration file for Apache.
+                       insinto "/etc/apache2/modules.d"
+                       doins "${FILESDIR}"/99_nagios4.conf
+               elif use lighttpd ; then
+                       # Install the Nagios configuration file for Lighttpd.
+                       insinto /etc/lighttpd
+                       newins "${FILESDIR}/lighttpd_nagios4.conf" nagios.conf
+               else
+                       ewarn "${CATEGORY}/${PF} only supports apache or lighttpd"
+                       ewarn "out of the box. Since you are not using one of them, you"
+                       ewarn "will have to configure your webserver yourself."
+               fi
+       fi
+}
+
+pkg_postinst() {
+
+       if use web; then
+               if use apache2 || use lighttpd ; then
+                       if use apache2; then
+                               elog "To enable the Nagios web front-end, please edit"
+                               elog "${ROOT}etc/conf.d/apache2 and add \"-D NAGIOS -D PHP\""
+                               elog "to APACHE2_OPTS. Then Nagios will be available at,"
+                               elog
+                       elif use lighttpd; then
+                               elog "To enable the Nagios web front-end, please add"
+                               elog "'include \"nagios.conf\"' to the lighttpd configuration"
+                               elog "file at ${ROOT}etc/lighttpd/lighttpd.conf. Then Nagios"
+                               elog "will be available at,"
+                               elog
+                       fi
+
+                       elog "  http://localhost/nagios/"
+               fi
+       fi
+
+       elog
+       elog "If your kernel has /proc protection, nagios"
+       elog "will not be happy as it relies on accessing the proc"
+       elog "filesystem. You can fix this by adding nagios into"
+       elog "the group wheel, but this is not recomended."
+       elog
+}