sys-devel/clang-runtime: Add 9.0 branch live ebuild
authorMichał Górny <mgorny@gentoo.org>
Sun, 21 Jul 2019 07:13:36 +0000 (09:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 21 Jul 2019 07:33:53 +0000 (09:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild [new file with mode: 0644]

diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild
new file mode 100644 (file)
index 0000000..2b4d595
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+# Note: keep it matching clang-9999 version
+SLOT="9.0.0"
+KEYWORDS=""
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+       compiler-rt? (
+               ~sys-libs/compiler-rt-${PV}:${SLOT}
+               sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+       )
+       crt? (
+               || (
+                       sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+                       sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+               )
+       )
+       libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+       openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"