Added patch to fix compilation when USE="doc -python" (bug #158638). New revision...
authorLeonardo Boshell <leonardop@gentoo.org>
Thu, 21 Dec 2006 11:17:45 +0000 (11:17 +0000)
committerLeonardo Boshell <leonardop@gentoo.org>
Thu, 21 Dec 2006 11:17:45 +0000 (11:17 +0000)
Package-Manager: portage-2.1.1-r2

app-editors/gedit/ChangeLog
app-editors/gedit/files/digest-gedit-2.16.2-r1 [new file with mode: 0644]
app-editors/gedit/files/gedit-2.16.2-no_python_module_docs.patch [new file with mode: 0644]
app-editors/gedit/gedit-2.16.2-r1.ebuild [new file with mode: 0644]
app-editors/gedit/gedit-2.16.2.ebuild

index d1e82c98c20508900cbbd7ff72b2620635d07111..78c9c7f828f7196ccc18e5a78bd2596ca3385328 100644 (file)
@@ -1,6 +1,18 @@
 # ChangeLog for app-editors/gedit
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.170 2006/12/18 16:04:33 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/ChangeLog,v 1.171 2006/12/21 11:17:45 leonardop Exp $
+
+*gedit-2.16.2-r1 (21 Dec 2006)
+
+  21 Dec 2006; Leonardo Boshell <leonardop@gentoo.org>
+  +gedit-2.16.2-r1.ebuild:
+  Actually enforce the meaning of the 'python' USE flag.
+
+  21 Dec 2006; Leonardo Boshell <leonardop@gentoo.org>
+  +files/gedit-2.16.2-no_python_module_docs.patch, gedit-2.16.2.ebuild:
+  Added patch to fix a compilation problem when USE="doc -python" and
+  gnome-python-desktop is not previously installed in the system (bug
+  #158638). Added gtk-doc and pygobject dependencies.
 
   18 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org> gedit-2.16.2.ebuild:
   Stable on sparc
diff --git a/app-editors/gedit/files/digest-gedit-2.16.2-r1 b/app-editors/gedit/files/digest-gedit-2.16.2-r1
new file mode 100644 (file)
index 0000000..1e6c806
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9ed4fb2891d07c022b487723d1c72161 gedit-2.16.2.tar.bz2 2851971
+RMD160 a15ff0981ee190453fe9a748a601ee03b14a890f gedit-2.16.2.tar.bz2 2851971
+SHA256 8c5c3d5319d060b0db15c30c48503fde85341fa0f1aa848e99c1f0b825c20b4e gedit-2.16.2.tar.bz2 2851971
diff --git a/app-editors/gedit/files/gedit-2.16.2-no_python_module_docs.patch b/app-editors/gedit/files/gedit-2.16.2-no_python_module_docs.patch
new file mode 100644 (file)
index 0000000..f1fa94f
--- /dev/null
@@ -0,0 +1,19 @@
+diff -NurdB gedit-2.16.2/docs/reference/gedit.types gedit-2.16.2-patched/docs/reference/gedit.types
+--- gedit-2.16.2/docs/reference/gedit.types     2006-10-29 18:32:53.000000000 +0000
++++ gedit-2.16.2-patched/docs/reference/gedit.types     2006-12-21 10:04:31.000000000 +0000
+@@ -10,7 +10,6 @@
+ #include "gedit-print.h"
+ #include "gedit-print-job-preview.h"
+ #include "gedit-progress-message-area.h"
+-#include "gedit-python-module.h"
+ #include "gedit-statusbar.h"
+ #include "gedit-tab.h"
+ #include "gedit-view.h"
+@@ -27,7 +26,6 @@
+ gedit_print_job_get_type
+ gedit_print_job_preview_get_type
+ gedit_progress_message_area_get_type
+-gedit_python_module_get_type
+ gedit_statusbar_get_type
+ gedit_tab_get_type
+ gedit_tooltips_get_type
diff --git a/app-editors/gedit/gedit-2.16.2-r1.ebuild b/app-editors/gedit/gedit-2.16.2-r1.ebuild
new file mode 100644 (file)
index 0000000..53a2ba2
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.16.2-r1.ebuild,v 1.1 2006/12/21 11:17:45 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc spell python"
+
+RDEPEND=">=gnome-base/gconf-2
+       >=dev-libs/glib-2.12
+       >=x11-libs/gtk+-2.10
+       >=x11-libs/gtksourceview-1.8.0
+       >=gnome-base/libgnomeui-2.16
+       >=gnome-base/libglade-2.5.1
+       >=gnome-base/libgnomeprintui-2.12.1
+       >=gnome-base/gnome-vfs-2.16
+       >=gnome-base/orbit-2
+       >=gnome-base/libbonobo-2
+       spell? ( virtual/aspell-dict )
+       python? (
+               >=dev-python/pygobject-2.11.5
+               >=dev-python/pygtk-2.9.7
+               >=dev-python/gnome-python-desktop-2.15.90 )"
+# FIXME : spell autodetect only
+
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       >=dev-util/pkgconfig-0.9
+       >=app-text/scrollkeeper-0.3.11
+       >=dev-util/intltool-0.35
+       >=app-text/gnome-doc-utils-0.3.2
+       doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README THANKS TODO"
+
+if [[ "${ARCH}" == "PPC" ]] ; then
+       MAKEOPTS="${MAKEOPTS} -j1"
+fi
+
+
+pkg_setup() {
+       G2CONF="$(use_enable python)"
+}
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # Remove symbols that are not meant to be part of the docs, and break
+       # compilation if USE="doc -python" (bug #158638).
+       epatch "${FILESDIR}"/${P}-no_python_module_docs.patch
+}
index ed0f4ff490882439ed08551e6a03eb3777fea66b..0e7796f4d65b86f20166c0897ae623420d2d0f45 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.16.2.ebuild,v 1.6 2006/12/18 16:04:33 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.16.2.ebuild,v 1.7 2006/12/21 11:17:45 leonardop Exp $
 
-inherit gnome2
+inherit eutils gnome2
 
 DESCRIPTION="A text editor for the GNOME desktop"
 HOMEPAGE="http://www.gnome.org/"
@@ -24,9 +24,9 @@ RDEPEND=">=gnome-base/gconf-2
        >=gnome-base/libbonobo-2
        spell? ( virtual/aspell-dict )
        python? (
+               >=dev-python/pygobject-2.11.5
                >=dev-python/pygtk-2.9.7
-               >=dev-python/gnome-python-desktop-2.15.90
-       )"
+               >=dev-python/gnome-python-desktop-2.15.90 )"
 # FIXME : spell autodetect only
 
 DEPEND="${RDEPEND}
@@ -34,10 +34,20 @@ DEPEND="${RDEPEND}
        >=dev-util/pkgconfig-0.9
        >=app-text/scrollkeeper-0.3.11
        >=dev-util/intltool-0.35
-       >=app-text/gnome-doc-utils-0.3"
+       >=app-text/gnome-doc-utils-0.3.2
+       doc? ( >=dev-util/gtk-doc-1 )"
 
 DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README THANKS TODO"
 
 if [[ "${ARCH}" == "PPC" ]] ; then
        MAKEOPTS="${MAKEOPTS} -j1"
 fi
+
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # Remove symbols that are not meant to be part of the docs, and break
+       # compilation if USE="doc -python" (bug #158638).
+       epatch "${FILESDIR}"/${P}-no_python_module_docs.patch
+}