dev-ml/ocaml-pcap: bump to 0.4.0
authorAlexis Ballier <aballier@gentoo.org>
Sun, 1 May 2016 18:44:19 +0000 (20:44 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 3 May 2016 09:13:52 +0000 (11:13 +0200)
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ocaml-pcap/Manifest
dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild [new file with mode: 0644]

index b066fa9184a9e2eec895113341d8a27797d3e32c..b395caa4c4633ea8ad2ddd0d2dd089120194970e 100644 (file)
@@ -1 +1,2 @@
 DIST ocaml-pcap-0.3.3.tar.gz 45752 SHA256 9419a1701310b2d9130be3d305a6e2cb0cb2c8da0348a6c9fc49bbe2a5d6ae76 SHA512 732f895c08b114aef34ea3b776c69d67696e290f2a2952405b75097ce0253fcc8a754dd223ac4ce98b134786f46c328cc2510f7313c4c8c4042d242a1a4de8a1 WHIRLPOOL 0a39017e791e1031b0f1500e3f9eb055db66dda3c35c0ba027f579f4a3066c824bb066733cce9ab07e37e679694bc909ef0b3c812b71570a1563e5a28121b00d
+DIST ocaml-pcap-0.4.0.tar.gz 52694 SHA256 abf4cd0da26ae70de26c7b395d53b1983ab4c9ab7f81322a1df56c039a373e6a SHA512 cbcd33d7a557f1a05e5f12013e8dbe226a81a64822689452614dffedeecf8641ce2498e9c9322f80066977ef56a4130ee016816911b6871609d11a988cfcad0e WHIRLPOOL 0b87ede6a7740dec323f8a5592e69f55af0dcd825cdfed4d9834a3d0059f7d5c90c6036e84e23d375f282454e4901dd2b0dbda2e4c854711a6999604ccb80a27
diff --git a/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild b/dev-ml/ocaml-pcap/ocaml-pcap-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..7d13ee5
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Read and write pcap-formatted network packet traces."
+HOMEPAGE="https://github.com/mirage/ocaml-pcap https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Blockers taken from opam file and only relevant
+# if MirageOS should enter portage.
+RDEPEND="
+       dev-ml/ocaml-ipaddr:=
+       !dev-ml/mirage-net-socket
+       !<dev-ml/mirage-0.9.2
+       >=dev-ml/ocaml-cstruct-0.6.0:=[ppx(-)]
+"
+DEPEND="
+       test? ( dev-ml/ounit
+               >=dev-ml/lwt-2.4.0 )
+       ${RDEPEND}
+"
+
+DOCS=( CHANGES MAINTAINERS README.md )