dev-python/pyaes: Add missing test dependency
authorMatt Turner <mattst88@gentoo.org>
Mon, 16 Mar 2020 20:06:30 +0000 (13:06 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 16 Mar 2020 20:06:43 +0000 (13:06 -0700)
Closes: https://bugs.gentoo.org/651262
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/pyaes/pyaes-1.6.1-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/pyaes/pyaes-1.6.1-r2.ebuild b/dev-python/pyaes/pyaes-1.6.1-r2.ebuild
new file mode 100644 (file)
index 0000000..2c3a310
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.org/project/pyaes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pycryptodome[${PYTHON_USEDEP}] )"
+
+python_test() {
+       local t fail=
+       for t in tests/test-*.py; do
+               einfo "${t}"
+               "${EPYTHON}" "${t}" || fail=1
+       done
+       [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
+}