dev-lang/rust: add packages for >=sys-devel/llvm-3.7.0
authorDoug Goldstein <cardoe@gentoo.org>
Wed, 30 Mar 2016 15:31:29 +0000 (10:31 -0500)
committerDoug Goldstein <cardoe@gentoo.org>
Wed, 30 Mar 2016 15:32:07 +0000 (10:32 -0500)
Because of changes Gentoo has made with how sys-devel/llvm is built
the way we have to depend on it has changed. LLVM 3.6.0 is only
a build time DEPEND. While LLVM 3.7.0 and newer is a run-time
RDEPEND and DEPEND. Since no EAPI provides a dynamic way for
packages to update RDEPEND we need to provide two different
packages so that people can build against LLVM 3.6.0 and LLVM
3.7.0 and newer.

Package-Manager: portage-2.2.26
Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
dev-lang/rust/rust-1.7.0-r100.ebuild [new file with mode: 0644]
dev-lang/rust/rust-1.8.0_beta20160323-r100.ebuild [new file with mode: 0644]

diff --git a/dev-lang/rust/rust-1.7.0-r100.ebuild b/dev-lang/rust/rust-1.7.0-r100.ebuild
new file mode 100644 (file)
index 0000000..1c94d49
--- /dev/null
@@ -0,0 +1,158 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 versionator toolchain-funcs
+
+if [[ ${PV} = *beta* ]]; then
+       betaver=${PV//*beta}
+       BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
+       MY_P="rustc-beta"
+       SLOT="beta/${PV}"
+       SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.gz"
+       KEYWORDS=""
+else
+       ABI_VER="$(get_version_component_range 1-2)"
+       SLOT="stable/${ABI_VER}"
+       MY_P="rustc-${PV}"
+       SRC="${MY_P}-src.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+# from src/snapshots.txt
+RUST_SNAPSHOT_DATE="2016-02-17"
+RUST_SNAPSHOT_SRCHASH="4d3eebf"
+RUST_SNAPSHOT_HASH_amd64="d29b7607d13d64078b6324aec82926fb493f59ba"
+RUST_SNAPSHOT_HASH_x86="5f194aa7628c0703f0fd48adc4ec7f3cc64b98c7"
+RUST_STAGE0="rust-stage0-${RUST_SNAPSHOT_DATE}-${RUST_SNAPSHOT_SRCHASH}"
+RUST_STAGE0_amd64="${RUST_STAGE0}-linux-x86_64-${RUST_SNAPSHOT_HASH_amd64}"
+RUST_STAGE0_x86="${RUST_STAGE0}-linux-i386-${RUST_SNAPSHOT_HASH_x86}"
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+
+SRC_URI="http://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.gz
+       amd64? ( http://static.rust-lang.org/stage0-snapshots/${RUST_STAGE0_amd64}.tar.bz2 )
+       x86? ( http://static.rust-lang.org/stage0-snapshots/${RUST_STAGE0_x86}.tar.bz2 )
+"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+
+IUSE="clang debug doc libcxx +system-llvm"
+REQUIRED_USE="libcxx? ( clang )"
+
+RDEPEND="libcxx? ( sys-libs/libcxx )
+       system-llvm? ( >=sys-devel/llvm-3.7.0[multitarget]
+               <sys-devel/llvm-3.8.0[multitarget] )
+"
+
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       >=dev-lang/perl-5.0
+       clang? ( sys-devel/clang )
+"
+
+PDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+       unpack "rustc-${PV}-src.tar.gz" || die
+       mkdir "${MY_P}/dl" || die
+       local stagename="RUST_STAGE0_${ARCH}"
+       local stage0="${!stagename}"
+       cp "${DISTDIR}/${stage0}.tar.bz2" "${MY_P}/dl/" || die "cp stage0"
+}
+
+src_prepare() {
+       find mk -name '*.mk' -exec \
+                sed -i -e "s/-Werror / /g" {} \; || die
+
+       eapply_user
+}
+
+src_configure() {
+       export CFG_DISABLE_LDCONFIG="notempty"
+
+       "${ECONF_SOURCE:-.}"/configure \
+               --prefix="${EPREFIX}/usr" \
+               --libdir="${EPREFIX}/usr/$(get_libdir)/${P}" \
+               --mandir="${EPREFIX}/usr/share/${P}/man" \
+               --release-channel=${SLOT%%/*} \
+               --disable-manage-submodules \
+               --default-linker=$(tc-getBUILD_CC) \
+               --default-ar=$(tc-getBUILD_AR) \
+               --python=${EPYTHON} \
+               $(use_enable clang) \
+               $(use_enable debug) \
+               $(use_enable debug llvm-assertions) \
+               $(use_enable !debug optimize) \
+               $(use_enable !debug optimize-cxx) \
+               $(use_enable !debug optimize-llvm) \
+               $(use_enable !debug optimize-tests) \
+               $(use_enable doc docs) \
+               $(use_enable libcxx libcpp) \
+               $(usex system-llvm "--llvm-root=${EPREFIX}/usr" " ") \
+               || die
+}
+
+src_compile() {
+       emake VERBOSE=1
+}
+
+src_install() {
+       unset SUDO_USER
+
+       default
+
+       mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
+       mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
+       mv "${D}/usr/bin/rust-gdb" "${D}/usr/bin/rust-gdb-${PV}" || die
+
+       dodoc COPYRIGHT
+
+       dodir "/usr/share/doc/rust-${PV}/"
+       mv "${D}/usr/share/doc/rust"/* "${D}/usr/share/doc/rust-${PV}/" || die
+       rmdir "${D}/usr/share/doc/rust/" || die
+
+       cat <<-EOF > "${T}"/50${P}
+       LDPATH="/usr/$(get_libdir)/${P}"
+       MANPATH="/usr/share/${P}/man"
+       EOF
+       doenvd "${T}"/50${P}
+
+       cat <<-EOF > "${T}/provider-${P}"
+       /usr/bin/rustdoc
+       /usr/bin/rust-gdb
+       EOF
+       dodir /etc/env.d/rust
+       insinto /etc/env.d/rust
+       doins "${T}/provider-${P}"
+}
+
+pkg_postinst() {
+       eselect rust update --if-unset
+
+       elog "Rust installs a helper script for calling GDB now,"
+       elog "for your convenience it is installed under /usr/bin/rust-gdb-${PV}."
+
+       if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+               elog "install app-emacs/rust-mode to get emacs support for rust."
+       fi
+
+       if has_version app-editors/gvim || has_version app-editors/vim; then
+               elog "install app-vim/rust-mode to get vim support for rust."
+       fi
+
+       if has_version 'app-shells/zsh'; then
+               elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+       fi
+}
+
+pkg_postrm() {
+       eselect rust unset --if-invalid
+}
diff --git a/dev-lang/rust/rust-1.8.0_beta20160323-r100.ebuild b/dev-lang/rust/rust-1.8.0_beta20160323-r100.ebuild
new file mode 100644 (file)
index 0000000..eb4b27d
--- /dev/null
@@ -0,0 +1,158 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 versionator toolchain-funcs
+
+if [[ ${PV} = *beta* ]]; then
+       betaver=${PV//*beta}
+       BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
+       MY_P="rustc-beta"
+       SLOT="beta/${PV}"
+       SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.gz"
+       KEYWORDS=""
+else
+       ABI_VER="$(get_version_component_range 1-2)"
+       SLOT="stable/${ABI_VER}"
+       MY_P="rustc-${PV}"
+       SRC="${MY_P}-src.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+# from src/snapshots.txt
+RUST_SNAPSHOT_DATE="2016-02-17"
+RUST_SNAPSHOT_SRCHASH="4d3eebf"
+RUST_SNAPSHOT_HASH_amd64="d29b7607d13d64078b6324aec82926fb493f59ba"
+RUST_SNAPSHOT_HASH_x86="5f194aa7628c0703f0fd48adc4ec7f3cc64b98c7"
+RUST_STAGE0="rust-stage0-${RUST_SNAPSHOT_DATE}-${RUST_SNAPSHOT_SRCHASH}"
+RUST_STAGE0_amd64="${RUST_STAGE0}-linux-x86_64-${RUST_SNAPSHOT_HASH_amd64}"
+RUST_STAGE0_x86="${RUST_STAGE0}-linux-i386-${RUST_SNAPSHOT_HASH_x86}"
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+
+SRC_URI="http://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.gz
+       amd64? ( http://static.rust-lang.org/stage0-snapshots/${RUST_STAGE0_amd64}.tar.bz2 )
+       x86? ( http://static.rust-lang.org/stage0-snapshots/${RUST_STAGE0_x86}.tar.bz2 )
+"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+
+IUSE="clang debug doc libcxx +system-llvm"
+REQUIRED_USE="libcxx? ( clang )"
+
+RDEPEND="libcxx? ( sys-libs/libcxx )
+       system-llvm? ( >=sys-devel/llvm-3.7.0[multitarget]
+               <sys-devel/llvm-3.9.0[multitarget] )
+"
+
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       >=dev-lang/perl-5.0
+       clang? ( sys-devel/clang )
+"
+
+PDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+       unpack "rustc-${PV}-src.tar.gz" || die
+       mkdir "${MY_P}/dl" || die
+       local stagename="RUST_STAGE0_${ARCH}"
+       local stage0="${!stagename}"
+       cp "${DISTDIR}/${stage0}.tar.bz2" "${MY_P}/dl/" || die "cp stage0"
+}
+
+src_prepare() {
+       find mk -name '*.mk' -exec \
+                sed -i -e "s/-Werror / /g" {} \; || die
+
+       eapply_user
+}
+
+src_configure() {
+       export CFG_DISABLE_LDCONFIG="notempty"
+
+       "${ECONF_SOURCE:-.}"/configure \
+               --prefix="${EPREFIX}/usr" \
+               --libdir="${EPREFIX}/usr/$(get_libdir)/${P}" \
+               --mandir="${EPREFIX}/usr/share/${P}/man" \
+               --release-channel=${SLOT%%/*} \
+               --disable-manage-submodules \
+               --default-linker=$(tc-getBUILD_CC) \
+               --default-ar=$(tc-getBUILD_AR) \
+               --python=${EPYTHON} \
+               $(use_enable clang) \
+               $(use_enable debug) \
+               $(use_enable debug llvm-assertions) \
+               $(use_enable !debug optimize) \
+               $(use_enable !debug optimize-cxx) \
+               $(use_enable !debug optimize-llvm) \
+               $(use_enable !debug optimize-tests) \
+               $(use_enable doc docs) \
+               $(use_enable libcxx libcpp) \
+               $(usex system-llvm "--llvm-root=${EPREFIX}/usr" " ") \
+               || die
+}
+
+src_compile() {
+       emake VERBOSE=1
+}
+
+src_install() {
+       unset SUDO_USER
+
+       default
+
+       mv "${D}/usr/bin/rustc" "${D}/usr/bin/rustc-${PV}" || die
+       mv "${D}/usr/bin/rustdoc" "${D}/usr/bin/rustdoc-${PV}" || die
+       mv "${D}/usr/bin/rust-gdb" "${D}/usr/bin/rust-gdb-${PV}" || die
+
+       dodoc COPYRIGHT
+
+       dodir "/usr/share/doc/rust-${PV}/"
+       mv "${D}/usr/share/doc/rust"/* "${D}/usr/share/doc/rust-${PV}/" || die
+       rmdir "${D}/usr/share/doc/rust/" || die
+
+       cat <<-EOF > "${T}"/50${P}
+       LDPATH="/usr/$(get_libdir)/${P}"
+       MANPATH="/usr/share/${P}/man"
+       EOF
+       doenvd "${T}"/50${P}
+
+       cat <<-EOF > "${T}/provider-${P}"
+       /usr/bin/rustdoc
+       /usr/bin/rust-gdb
+       EOF
+       dodir /etc/env.d/rust
+       insinto /etc/env.d/rust
+       doins "${T}/provider-${P}"
+}
+
+pkg_postinst() {
+       eselect rust update --if-unset
+
+       elog "Rust installs a helper script for calling GDB now,"
+       elog "for your convenience it is installed under /usr/bin/rust-gdb-${PV}."
+
+       if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+               elog "install app-emacs/rust-mode to get emacs support for rust."
+       fi
+
+       if has_version app-editors/gvim || has_version app-editors/vim; then
+               elog "install app-vim/rust-mode to get vim support for rust."
+       fi
+
+       if has_version 'app-shells/zsh'; then
+               elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+       fi
+}
+
+pkg_postrm() {
+       eselect rust unset --if-invalid
+}