app-shells/zsh-syntax-highlighting: Version bump (v0.7.1)
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 29 Feb 2020 07:30:06 +0000 (10:30 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 29 Feb 2020 07:30:06 +0000 (10:30 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-shells/zsh-syntax-highlighting/Manifest
app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild [new file with mode: 0644]

index a557f61f9dd0de00c2b323d39de0b9a39b777c69..30131156c19943c895969a6af09d70606624093e 100644 (file)
@@ -1 +1,2 @@
 DIST zsh-syntax-highlighting-0.7.0_beta1.tar.gz 130063 BLAKE2B cf0f6319af22b47cb8a280de682a69b0479dc59033be5ce84840507b77dd2df0441b8d260af55bccb303c87d7f5a7e4cc6db9f46860aee040b4b8115c76f5e07 SHA512 1692015aad58103c752e2dd4161ea87f26aaa09d34eb2faec1f651fea1d9bfad29226455468017160a5393a87c1f7ed0514b09b0802b1810377beef72bfa6c87
+DIST zsh-syntax-highlighting-0.7.1.tar.gz 133554 BLAKE2B cd55a0ad69670b25edc4bfa78ad76d1e2ef501deeca3e93adbef0aca305896722b4906d7717be3ad61bc0cf6b6496e217626406e5ff4168ece4b75bffd94bbf0 SHA512 e7e86b88cdac9b9ed5f973823ba8efff99dd720b9ed929f765f9f9266b9d6e147274f5957ceb630d51a660e396fc22e97f10cfbc5cdde941b907f3773bb1ea2b
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.7.1.ebuild
new file mode 100644 (file)
index 0000000..8ca8ffb
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+if [[ -z ${PV%%*9999} ]]; then
+       EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+       inherit git-r3
+else
+       MY_PV=$(ver_rs 3 -)
+       SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-functions/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc"
+
+src_prepare() {
+       sed -i -e 's/COPYING.md//' Makefile || die
+       default
+}
+
+src_install() {
+       emake \
+               SHARE_DIR="${ED}/usr/share/zsh/site-functions" \
+               DOC_DIR="${ED}/usr/share/doc/${PF}" \
+               install
+       readme.gentoo_create_doc
+}