app-i18n/ibus-typing-booster: new upstream release
authorAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:16:48 +0000 (18:16 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:18:24 +0000 (18:18 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-typing-booster/Manifest
app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild [new file with mode: 0644]

index 784179cf17b6c79eb3ef985a62e7b01de8ad2194..a5ccf0b5033284222f6184ba90570bd2499ce8a8 100644 (file)
@@ -1,2 +1,3 @@
 DIST ibus-typing-booster-2.7.0.tar.gz 7364094 BLAKE2B 60a45121b398032b2581d1f3e5929e74e69ee22bf0807b069529afb30797daacece47e83b0696397e6b9c3f6adc28012c7f2b7102387e03eb360383946e836b2 SHA512 a11d2cad660dc813022eda89bb690e3fe7cd517ad6a3cbc7f31879afb60c5d1628f25beb423f922b26d7dd92c685471c767084cdd3a35aff1e2314a21cd757c1
 DIST ibus-typing-booster-2.8.0.tar.gz 8018809 BLAKE2B 9306b980623094a8b72d6824292d8d52a90df69b7f1f7df11c0df63c5d2c4f2aa1ca4e2765320096915b30cc807fbe24f64a219c3beb1bec4a1d81be4511779a SHA512 64c112275ec63ac3d3c13202256be8bfded152da7b08dde7e6eb01dd38fd48535d63daaa6c2fcc09e64dcd4927931380ccd0a0be739f04330fb15dc0d4fe1823
+DIST ibus-typing-booster-2.8.2.tar.gz 8161995 BLAKE2B 79c7bacb7c5a07139c710ddf063b58ed6bc15d1f58529dfaa0d8f1935cb513fe27ad5e95af0ca7383922f5642d1197cf74183ba2463a3fa81637add5d8376691 SHA512 3dffc21aae59ebc8c7b3ef3df588f958b4a42a2025dc6a82613e9bb1b324f8c999d01b8d98ed48794b3ea8fd5c3221df489a88f8c54c154a69be9908beda85b5
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.2.ebuild
new file mode 100644 (file)
index 0000000..2c9d4d4
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+       dev-libs/m17n-lib
+       $(python_gen_cond_dep '
+               app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+               dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+               dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+               dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+       ')"
+RDEPEND="${CDEPEND}
+       >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       virtual/pkgconfig"