x11-base/xorg-server: Enable glamor with USE=-minimal
authorMatt Turner <mattst88@gentoo.org>
Sun, 3 Nov 2019 21:55:57 +0000 (13:55 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sun, 3 Nov 2019 22:12:33 +0000 (14:12 -0800)
It only adds a dependency on media-libs/libepoxy which is small and used
by many other packages. glamor can be disabled at runtime with Option
"AccelMethod" in xorg.conf.

Closes: https://bugs.gentoo.org/698114
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-base/xorg-server/metadata.xml
x11-base/xorg-server/xorg-server-1.20.5.ebuild
x11-base/xorg-server/xorg-server-9999.ebuild

index b3f0d6f2cdee1364127c26574634da99091c63da..2e8d8799f905e6f50b30d4386d31be374d85ccaf 100644 (file)
@@ -8,7 +8,6 @@
 <use>
        <flag name="dmx">Build the Distributed Multiheaded X server</flag>
        <flag name="elogind">Use elogind to get control over framebuffer when running as regular user</flag>
-       <flag name="glamor">Enable Glamor OpenGL 2D acceleration</flag>
        <flag name="kdrive">Build the kdrive X servers</flag>
        <flag name="libglvnd">Use libglvnd for dispatch.</flag>
        <flag name="unwind">Enable libunwind usage for backtraces</flag>
index 601e6ae7a361f790abf61f2f017bc299424944b0..8f859c2eaf577d6f7f67bae889a6352a17d14506 100644 (file)
@@ -15,7 +15,7 @@ if [[ ${PV} != 9999* ]]; then
 fi
 
 IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug elogind +glamor ipv6 libressl libglvnd minimal selinux +suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug elogind ipv6 libressl libglvnd minimal selinux +suid systemd +udev unwind xcsecurity"
 
 CDEPEND="libglvnd? (
                media-libs/libglvnd
@@ -52,11 +52,6 @@ CDEPEND="libglvnd? (
                >=x11-libs/libXres-1.0.3
                >=x11-libs/libXtst-1.0.99.2
        )
-       glamor? (
-               media-libs/libepoxy[X,egl(+)]
-               >=media-libs/mesa-18[egl,gbm]
-               !x11-libs/glamor
-       )
        kdrive? (
                >=x11-libs/libXext-1.0.5
                x11-libs/libXv
@@ -72,7 +67,8 @@ CDEPEND="libglvnd? (
        !minimal? (
                >=x11-libs/libX11-1.1.5
                >=x11-libs/libXext-1.0.5
-               >=media-libs/mesa-18[X(+)]
+               >=media-libs/mesa-18[X(+),egl,gbm]
+               media-libs/libepoxy[X,egl(+)]
        )
        udev? ( virtual/libudev:= )
        unwind? ( sys-libs/libunwind )
@@ -119,7 +115,7 @@ REQUIRED_USE="!minimal? (
        )
        elogind? ( udev )
        ?? ( elogind systemd )
-       minimal? ( !glamor !wayland )
+       minimal? ( !wayland )
        xephyr? ( kdrive )"
 
 UPSTREAMED_PATCHES=(
@@ -136,9 +132,10 @@ PATCHES=(
 )
 
 pkg_setup() {
-       if use wayland && ! use glamor; then
+       if use wayland && use minimal; then
                ewarn "glamor is necessary for acceleration under Xwayland."
                ewarn "Performance may be unacceptable without it."
+               ewarn "Build with USE=-minimal to enable glamor."
        fi
 
        # localstatedir is used for the log location; we need to override the default
@@ -150,7 +147,6 @@ pkg_setup() {
                $(use_enable ipv6)
                $(use_enable debug)
                $(use_enable dmx)
-               $(use_enable glamor)
                $(use_enable kdrive)
                $(use_enable unwind libunwind)
                $(use_enable wayland xwayland)
@@ -159,6 +155,7 @@ pkg_setup() {
                $(use_enable !minimal dri)
                $(use_enable !minimal dri2)
                $(use_enable !minimal dri3)
+               $(use_enable !minimal glamor)
                $(use_enable !minimal glx)
                $(use_enable xcsecurity)
                $(use_enable xephyr)
index e9c4e0045348a5768f5e5e79c6e588b43f7ccb9e..25dac9a8620a0b98c745cb69e2e2cdd72246282a 100644 (file)
@@ -4,6 +4,7 @@
 EAPI=7
 
 XORG_DOC=doc
+XORG_EAUTORECONF="yes"
 inherit xorg-3 multilib flag-o-matic
 EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
 
@@ -14,7 +15,7 @@ if [[ ${PV} != 9999* ]]; then
 fi
 
 IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug elogind +glamor ipv6 libressl libglvnd minimal selinux +suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug elogind ipv6 libressl libglvnd minimal selinux +suid systemd +udev unwind xcsecurity"
 
 CDEPEND="libglvnd? (
                media-libs/libglvnd
@@ -51,11 +52,6 @@ CDEPEND="libglvnd? (
                >=x11-libs/libXres-1.0.3
                >=x11-libs/libXtst-1.0.99.2
        )
-       glamor? (
-               media-libs/libepoxy[X,egl(+)]
-               >=media-libs/mesa-18[egl,gbm]
-               !x11-libs/glamor
-       )
        kdrive? (
                >=x11-libs/libXext-1.0.5
                x11-libs/libXv
@@ -71,7 +67,8 @@ CDEPEND="libglvnd? (
        !minimal? (
                >=x11-libs/libX11-1.1.5
                >=x11-libs/libXext-1.0.5
-               >=media-libs/mesa-18[X(+)]
+               >=media-libs/mesa-18[X(+),egl,gbm]
+               media-libs/libepoxy[X,egl(+)]
        )
        udev? ( virtual/libudev:= )
        unwind? ( sys-libs/libunwind )
@@ -118,7 +115,7 @@ REQUIRED_USE="!minimal? (
        )
        elogind? ( udev )
        ?? ( elogind systemd )
-       minimal? ( !glamor !wayland )
+       minimal? ( !wayland )
        xephyr? ( kdrive )"
 
 UPSTREAMED_PATCHES=(
@@ -132,9 +129,10 @@ PATCHES=(
 )
 
 pkg_setup() {
-       if use wayland && ! use glamor; then
+       if use wayland && use minimal; then
                ewarn "glamor is necessary for acceleration under Xwayland."
                ewarn "Performance may be unacceptable without it."
+               ewarn "Build with USE=-minimal to enable glamor."
        fi
 
        # localstatedir is used for the log location; we need to override the default
@@ -146,7 +144,6 @@ pkg_setup() {
                $(use_enable ipv6)
                $(use_enable debug)
                $(use_enable dmx)
-               $(use_enable glamor)
                $(use_enable kdrive)
                $(use_enable unwind libunwind)
                $(use_enable wayland xwayland)
@@ -155,6 +152,7 @@ pkg_setup() {
                $(use_enable !minimal dri)
                $(use_enable !minimal dri2)
                $(use_enable !minimal dri3)
+               $(use_enable !minimal glamor)
                $(use_enable !minimal glx)
                $(use_enable xcsecurity)
                $(use_enable xephyr)