Bump to 3.5.1; remove old versions that can no longer be downloaded; thanks to Konrad...
authorCharlie Shepherd <masterdriverz@gentoo.org>
Mon, 1 Jan 2007 21:49:58 +0000 (21:49 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Mon, 1 Jan 2007 21:49:58 +0000 (21:49 +0000)
Package-Manager: portage-2.1.2_rc4-r3

app-editors/xxe/ChangeLog
app-editors/xxe/files/digest-xxe-3.5.1 [new file with mode: 0644]
app-editors/xxe/xxe-3.5.1.ebuild [new file with mode: 0644]

index 23e66a5035aa735cf127c32aef9069a37d0f0be8..69d26b809457631f6de62f825076e27e3e9c8fe1 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-editors/xxe
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/ChangeLog,v 1.29 2006/12/26 19:31:57 masterdriverz Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/ChangeLog,v 1.30 2007/01/01 21:49:58 masterdriverz Exp $
+
+*xxe-3.5.1 (01 Jan 2007)
+
+  01 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+  -xxe-3.4.0.ebuild, -xxe-3.5.0.ebuild, +xxe-3.5.1.ebuild:
+  Bump to 3.5.1; remove old versions that can no longer be downloaded; thanks
+  to Konrad Karczewski for reporting; bug 159619
 
 *xxe-3.5.0 (26 Dec 2006)
 
diff --git a/app-editors/xxe/files/digest-xxe-3.5.1 b/app-editors/xxe/files/digest-xxe-3.5.1
new file mode 100644 (file)
index 0000000..d71f0ff
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b964f822af35fdfa0af133b6e04d7e78 xxe-std-3_5_1.tar.gz 12214264
+RMD160 4c2e0d13c285ec2eabb0551dd8b87c10890aca33 xxe-std-3_5_1.tar.gz 12214264
+SHA256 212a192443d24ff12c2d6eddcfed7d39e3701a6dded94ef6cd292f73c80b8223 xxe-std-3_5_1.tar.gz 12214264
diff --git a/app-editors/xxe/xxe-3.5.1.ebuild b/app-editors/xxe/xxe-3.5.1.ebuild
new file mode 100644 (file)
index 0000000..6d326ec
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xxe/xxe-3.5.1.ebuild,v 1.1 2007/01/01 21:49:58 masterdriverz Exp $
+
+MY_PV="${PV//./_}"
+
+DESCRIPTION="The XMLmind XML Editor"
+SRC_URI="http://www.xmlmind.net/xmleditor/_download/${PN}-std-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.xmlmind.com/xmleditor/index.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc"
+
+RESTRICT="nostrip nomirror"
+
+DEPEND=""
+RDEPEND=">=virtual/jre-1.4.1"
+
+S="${WORKDIR}/${PN}-std-${MY_PV}"
+INSTALLDIR="/opt/${PN}"
+
+src_install() {
+       dodir "${INSTALLDIR}"
+       dirs="bin addon demo"
+       use doc && dirs="${dirs} doc"
+       for d in $dirs; do
+               cp -pPR "${S}/${d}" "${D}/${INSTALLDIR}"
+       done
+
+       chmod -x "${D}/${INSTALLDIR}"/bin/*.bat
+       chmod -x "${D}/${INSTALLDIR}"/bin/*.exe
+       chmod -x "${D}/${INSTALLDIR}"/bin/mac/{mkapp,JavaApplicationStub}
+
+       echo -e "PATH=${INSTALLDIR}/bin\nROOTPATH=${INSTALLDIR}" > "${T}/10xxe"
+       doenvd "${T}/10xxe"
+
+       insinto /usr/share/applications
+       doins "${FILESDIR}/xxe.desktop"
+}
+
+pkg_postinst() {
+       einfo "XXE has been installed in /opt/xxe, to include this"
+       einfo "in your path, run the following:"
+       einfo "    /usr/sbin/env-update && source /etc/profile"
+       echo
+       ewarn "If you need special/accented characters, you'll need to export LANG"
+       ewarn "to your locale.  Example: export LANG=es_ES.ISO8859-1"
+       ewarn "See http://www.xmlmind.com/xmleditor/user_faq.html#linuxlocale"
+}