dev-python/python-swiftclient: bup
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 27 Feb 2017 03:53:48 +0000 (21:53 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 27 Feb 2017 04:26:22 +0000 (22:26 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/python-swiftclient/Manifest
dev-python/python-swiftclient/python-swiftclient-3.3.0.ebuild [new file with mode: 0644]

index 91338f3f1e4b1b0b7973b85bd5257655826554ff..8aec158a30eed518fb68299259d68afbd560dca1 100644 (file)
@@ -1,2 +1,3 @@
 DIST python-swiftclient-3.0.0.tar.gz 134376 SHA256 824b8f204c5a7764de51795256e4175fdcd655ae4df85b8ae6e6ea9ec0b41f68 SHA512 4e81504876fb81bf74c3a3e034958c4783a4a9c2c426b7ae849e1968f98d9886c2299c2e67a2b366d6d4721b4635cef90ff49201ba9a4c86da9d61bfb96fa350 WHIRLPOOL d48902f331d04b3250dc6a90aa44f31d403012e10e1617a2fa52cb05b3d615293efc65a4f35872ec019254c096e44a79544d314cd1d4e6065e8e093febb3b3b7
 DIST python-swiftclient-3.1.0.tar.gz 155598 SHA256 7bb5984862b85ba2a18c16b4dc6af2fd14272871ad165eec47e9da111ab3fb9a SHA512 693fcea571721e2f578a21b05a3c908dd6621bcfdd70f09003a981e233e2b3061318d60e301dcfdbb03d08a326ca3f14f3297d8226b5a0a6d78f88b1a72b2ea4 WHIRLPOOL eaf7c4e78e2b642fa124c5044136fffe530450cbabf5bc4132e7d7e2f93d06dcfa2f6a4751e32a6ba1d90abf060ffd9eec679d3ece973594de9650e53557ee5f
+DIST python-swiftclient-3.3.0.tar.gz 166092 SHA256 8b4d38d73ceb2ef4984b39fb924bf9b265050ca2beb5c6bf29cb9f34ccd0bf7d SHA512 03e00e9b1f0f7b71c07e845cd9636031c15beb21a66495ab96be05df7e453160840948696ecb0d65d08c32e318d16425444aaa4ea16ede8268a2cf2b171a3987 WHIRLPOOL f1caa5dea37d3f727642d4e70308e8810d41e8e93716188159bd2b511518047bc12acb62dd1ab3631cf17ddfa773a7c7913093902ff8804f96dddd036cac3722
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.3.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.3.0.ebuild
new file mode 100644 (file)
index 0000000..fbfbecc
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/pbr[${PYTHON_USEDEP}]
+       test? (
+               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+               >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+       )"
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]
+       >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+       >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
+
+python_prepare_all() {
+       sed -i '/hacking/d' "${S}/test-requirements.txt" || die "sed failed"
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_test() {
+       testr init
+       testr run || die "tests failed under python2_7"
+       flake8 tests && einfo "run of tests folder by flake8 passed"
+       flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
+       distutils-r1_python_install_all
+}