dev-python/yappi: New package, Yet Another Python Profiler
authorPatrick McLean <chutzpah@gentoo.org>
Thu, 10 Sep 2015 20:40:54 +0000 (13:40 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 10 Sep 2015 20:40:54 +0000 (13:40 -0700)
dev-python/yappi/Manifest [new file with mode: 0644]
dev-python/yappi/yappi-0.93.ebuild [new file with mode: 0644]

diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
new file mode 100644 (file)
index 0000000..fc3a629
--- /dev/null
@@ -0,0 +1 @@
+DIST yappi-0.93.tar.gz 24367 SHA256 09c028fafb31423a46305d3dc55cf30734b66ec4607541d1b561a2ddb17d2081 SHA512 5e187c3502f44a83d2dd91809ba73d1509c3d9300a038a32ef18a128e8ad5582f888844ec9f3237606d09b447e9fa7b12add132aa723dbb1cea61d628f26331d WHIRLPOOL 4cd9a3f2a8f340a4d86d2aa0c08b56cc2531ac20887da587350b080422110331edb506626b43b902e2a5edc00a816e530920442f97f0c2fc18282d1402a4dfb5
diff --git a/dev-python/yappi/yappi-0.93.ebuild b/dev-python/yappi/yappi-0.93.ebuild
new file mode 100644 (file)
index 0000000..9a4b29d
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://bitbucket.org/sumerc/yappi/"
+SRC_URI="https://bitbucket.org/sumerc/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+       esetup.py test
+}