app-shells/sash: port to EAPI 7
authorAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 00:33:14 +0000 (19:33 -0500)
committerAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 00:33:31 +0000 (19:33 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
app-shells/sash/sash-3.8.ebuild

index 6c2ee580ce0438665a9d36404e625db263d15fb7..e584cdbcd922f437cb8927a9c7b4ad57bf9c62cb 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit eutils toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic
 
 DESCRIPTION="A small (static) UNIX Shell"
-HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
-SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+HOMEPAGE="https://www.canb.auug.org.au/~dbell/"
+SRC_URI="https://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
 
 LICENSE="freedist"
 SLOT="0"
@@ -20,7 +20,7 @@ DEPEND="
 RDEPEND="!static? ( ${DEPEND} )"
 
 src_prepare() {
-       epatch "${FILESDIR}"/sash-3.7-builtin.patch
+       eapply "${FILESDIR}"/sash-3.7-builtin.patch
 
        sed \
                -e "s:-O3:${CFLAGS}:" \
@@ -29,6 +29,7 @@ src_prepare() {
        sed \
                -e 's:linux/ext2_fs.h:ext2fs/ext2_fs.h:g' \
                -i cmd_chattr.c || die
+       eapply_user
 }
 
 src_compile() {
@@ -38,7 +39,6 @@ src_compile() {
 }
 
 src_install() {
-       into /
        dobin sash
        doman sash.1
        dodoc README