sci-chemistry/chemical-mime-data: Drop problematic mime type
authorPacho Ramos <pacho@gentoo.org>
Fri, 7 Feb 2020 18:35:45 +0000 (19:35 +0100)
committerPacho Ramos <pacho@gentoo.org>
Fri, 7 Feb 2020 18:41:07 +0000 (19:41 +0100)
Bug: https://bugs.gentoo.org/701900
Closes: https://bugs.gentoo.org/707284
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r4.ebuild [new file with mode: 0644]
sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-drop-turbomole-vibrational.patch [new file with mode: 0644]

diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r4.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94-r4.ebuild
new file mode 100644 (file)
index 0000000..ad703d6
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg
+
+DESCRIPTION="A collection of data files to add support for chemical MIME types"
+HOMEPAGE="https://github.com/dleidert/chemical-mime"
+SRC_URI="mirror://sourceforge/${PN/-data/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       x11-misc/shared-mime-info
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/intltool
+       dev-util/desktop-file-utils
+       dev-libs/libxslt
+       || (
+               gnome-base/librsvg
+               media-gfx/imagemagick[xml,png,svg]
+       )
+       media-gfx/imagemagick[png]
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-turbomole.patch
+       "${FILESDIR}"/${P}-pigz.patch
+       "${FILESDIR}"/${P}-namespace-svg.patch
+       "${FILESDIR}"/${P}-rsvg-convert.patch
+       # https://github.com/dleidert/chemical-mime/issues/1
+       "${FILESDIR}"/${P}-drop-turbomole-vibrational.patch
+)
+
+src_prepare() {
+       xdg_src_prepare
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --disable-update-database \
+               --without-gnome-mime \
+               --without-pixmaps \
+               --without-kde-mime \
+               --htmldir=/usr/share/doc/${PF}/html
+}
diff --git a/sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-drop-turbomole-vibrational.patch b/sci-chemistry/chemical-mime-data/files/chemical-mime-data-0.1.94-drop-turbomole-vibrational.patch
new file mode 100644 (file)
index 0000000..4c25b1a
--- /dev/null
@@ -0,0 +1,20 @@
+diff -up chemical-mime-data-0.1.94/src/chemical-mime-database.xml.in.turbomole_vibration chemical-mime-data-0.1.94/src/chemical-mime-database.xml.in
+--- chemical-mime-data-0.1.94/src/chemical-mime-database.xml.in.turbomole_vibration    2020-01-29 17:32:45.000000000 +0100
++++ chemical-mime-data-0.1.94/src/chemical-mime-database.xml.in        2020-01-29 17:32:45.000000000 +0100
+@@ -1401,16 +1401,6 @@
+               <specification url="http://www.cosmologic.de/data/DOK_HTML/"/>
+       </mime-type>
+-      <mime-type type="chemical/x-turbomole-vibrational" support="yes">
+-              <_comment>Turbomole Vibrational Data File</_comment>
+-              <glob pattern="???"/>
+-              <sub-class-of type="text/plain"/>
+-              <icon kde="qc"/>
+-              <supported-by>
+-                      <application name="viewmol"/>
+-              </supported-by>
+-              <specification url="http://www.cosmologic.de/data/DOK_HTML/"/>
+-      </mime-type>
+
+       <mime-type type="chemical/x-vamas-iso14976" cm:support="no">
+               <_comment>VAMAS document</_comment>