dev-python/pyghmi: 1.0.22-r1 revbump
authorZac Medico <zmedico@gentoo.org>
Sun, 26 Jan 2020 21:09:13 +0000 (13:09 -0800)
committerZac Medico <zmedico@gentoo.org>
Sun, 26 Jan 2020 21:21:29 +0000 (13:21 -0800)
Remove dev-python/hacking test dep.

Reported-by: Matthew Thode <prometheanfire@gentoo.org>
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild [moved from dev-python/pyghmi/pyghmi-1.0.22.ebuild with 87% similarity]

similarity index 87%
rename from dev-python/pyghmi/pyghmi-1.0.22.ebuild
rename to dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild
index 39164e26ed170d325193d93df73d0745b9c57dee..d825c3250b25f8753e8534be53ea0914c2bc9ed1 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
@@ -16,8 +16,7 @@ KEYWORDS="~amd64 ~x86"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
-       >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
 #636824 older versions of cli_helpers break the build
 DEPEND="${RDEPEND}
        !<dev-python/cli_helpers-1.0.0
@@ -25,7 +24,6 @@ DEPEND="${RDEPEND}
        test? (
                >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
                >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
-               >=dev-python/hacking-0.5[${PYTHON_USEDEP}]
                >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
                >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
                >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
@@ -35,6 +33,11 @@ DEPEND="${RDEPEND}
                >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
        )"
 
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       sed '/^pycrypto>=2\.6$/d' -i requirements.txt || die
+}
+
 python_test() {
        esetup.py testr --coverage || die "Tests failed under ${EPYTHON}"
 }