dev-python/plyvel: bump to 1.1.0, make pytest verbose
authorLouis Sautier <sbraz@gentoo.org>
Thu, 2 May 2019 22:28:27 +0000 (00:28 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Thu, 2 May 2019 22:30:58 +0000 (00:30 +0200)
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/plyvel/Manifest
dev-python/plyvel/plyvel-1.1.0.ebuild [new file with mode: 0644]

index 2677873a4a73cb197c09f1f84b923f06d66fd9b7..6c7646582d548ecbca1691f1b63ce7abac21555c 100644 (file)
@@ -1,2 +1,3 @@
 DIST plyvel-1.0.4.tar.gz 338470 BLAKE2B dbc33ac9962ed3b74d83158e973ac956bd9fa81c7e1980c1d79187f6e629d0605d821debe4bfd4532120f343b87ee3acd825514884d78b471d3717364837ce42 SHA512 ee397d4f7e2dac4e7b382841559895184dc0356b84da4ff4ccdad43c32aebcb1dcc5020230a5564c875ed5d4401cc8b009438ca3b2e0b50e6467e384f0366171
 DIST plyvel-1.0.5.tar.gz 143728 BLAKE2B 2eac687e6901381b62df5278abe00684c8e5a9ac162596a1a1a0e620536155b5e5c0ba0ab9bb32c1d3a6467d997cfdf530e9275024f8caba3323728f3f3aba67 SHA512 d2a7fe9d49b377135ece03292f366423e9550d3440689a99246d8c5ddc38e474c2b05c709655c6bf74a1d04f742a23dfb8841b51698c2adb062418577b28c4b4
+DIST plyvel-1.1.0.tar.gz 143970 BLAKE2B 980c8117f39c704abaf1733bfabb6816aa84e5e449ed37368038a7d6cd4cbbbf832319bf149ec6ae7cca5074984427df08afc50e033451d3d97ddafd210d91e0 SHA512 4d9b20f7e047d75af14d530519b4360194a18aa423a57ac4596441e47528bbc9f8e3ff763dd91da4c115cb1e4a6f34f01bbd47f4be49be110b2f6e3c7b8bdb3a
diff --git a/dev-python/plyvel/plyvel-1.1.0.ebuild b/dev-python/plyvel/plyvel-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..be42e62
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
+PYTHON_COMPAT=( pypy3 python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to LevelDB"
+HOMEPAGE="https://github.com/wbolster/plyvel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/leveldb-1.20:="
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile() {
+       # https://wiki.gentoo.org/wiki/Project:Python/Strict_aliasing
+       python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+       distutils-r1_python_compile
+}
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build doc doc/_build/html || die
+               HTML_DOCS=( doc/_build/html/. )
+       fi
+}
+
+python_test() {
+       # We need to copy the extension to the package folder
+       local ext="$(ls "${BUILD_DIR}/lib/${PN}/"*.so | head -n1 || die)"
+       ln -s "${ext}" "${PN}" || die
+       pytest -vv || die "tests failed with ${EPYTHON}"
+       rm "${PN}/$(basename "${ext}")" || die
+}