dev-libs/mxml: drop old version
authorConrad Kostecki <conikost@gentoo.org>
Wed, 25 Dec 2019 13:33:34 +0000 (14:33 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Wed, 25 Dec 2019 13:33:34 +0000 (14:33 +0100)
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
dev-libs/mxml/Manifest
dev-libs/mxml/mxml-3.0.ebuild [deleted file]

index cec6fece84f9bc697bf19fcbf81d0204986ce4ed..1558e0e60483b24855af1631552c2919d7f4536f 100644 (file)
@@ -1,2 +1 @@
-DIST mxml-3.0.tar.gz 9266886 BLAKE2B d5d3481cfd1d015c620ef897bfc21e839ad2a70f5ffd58973f8435e0e6a66abd477f8fcaacfab05ce608314fed27241702becb60b49b8492560bcc9418b317f5 SHA512 3c540348022226b122ce014f183368cda6631600a11d8f4d43c99c62fba2f3ca4b23dff4122082f63915b59a46a5475d1d12d0081f9315c65f5c044ac3c751d6
 DIST mxml-3.1.tar.gz 9267206 BLAKE2B d5cee24804978b474bf5b58c7a5932b50d7197a35e65da20c2517ce7db01d22027449348d6b15ddf0d186219ac81993055deaa4af9f48439273f8d2d74b27edd SHA512 8f8923b394093db5c471c52c17185916bc3c91f66c97de66919bfef2a09f271879a52f285e5fc4ded03484a3f83ba8fdb588d985b06e0c25ee001f1a80ffa586
diff --git a/dev-libs/mxml/mxml-3.0.ebuild b/dev-libs/mxml/mxml-3.0.ebuild
deleted file mode 100644 (file)
index 11e6531..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
-HOMEPAGE="
-       https://github.com/michaelrsweet/mxml
-       https://www.msweet.org/mxml/
-"
-SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Mini-XML"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
-IUSE="static-libs threads"
-
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
-       default
-
-       # Respect users CFLAGS
-       sed -e 's/-Os -g//' -i configure.ac || die
-
-       # Don't run always tests
-       # Enable verbose compiling
-       sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
-
-       # Build only static-libs, when requested by user, also build docs without static-libs in that case
-       if ! use static-libs; then
-               local mysedopts=(
-                       -e '/^install:/s/install-libmxml.a//g'
-                       -e '/^mxml.xml:/s/-static//g'
-                       -e '/^mxml.epub:/s/-static//g'
-                       -e '/^valgrind/s/-static//g'
-                       -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
-               )
-               sed "${mysedopts[@]}" -i Makefile.in || die
-       fi
-
-       eautoconf
-}
-
-src_configure() {
-       local myeconfopts=(
-               $(use_enable threads)
-               --with-docdir=/usr/share/doc/"${PF}"
-       )
-
-       econf "${myeconfopts[@]}"
-}
-
-src_test() {
-       emake testmxml
-}
-
-src_install() {
-       emake DSTROOT="${ED}" install
-}