gnome-extra/cinnamon-control-center: 4.4.0 version bump
authorMatthew Turnbull <sparky@bluefang-logic.com>
Wed, 13 May 2020 03:19:55 +0000 (23:19 -0400)
committerMatt Turner <mattst88@gentoo.org>
Fri, 29 May 2020 00:10:46 +0000 (17:10 -0700)
Update cinnamon-control-center to 4.4.0. CUPS dependencies
belong in cinnamon-settings-daemon. Make networkmanager
and modemmanager optional. Clean-up dead configure options.

Bug: https://bugs.gentoo.org/553946
Bug: https://bugs.gentoo.org/704532
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
gnome-extra/cinnamon-control-center/Manifest
gnome-extra/cinnamon-control-center/cinnamon-control-center-4.4.0.ebuild [new file with mode: 0644]
gnome-extra/cinnamon-control-center/metadata.xml

index baa9aeae6b9fb80ccd815027762b361b3ba74148..50f1ed1ec76252e2f4d4ae49d3ae97701b019e12 100644 (file)
@@ -1 +1,2 @@
 DIST cinnamon-control-center-4.0.0.tar.gz 3872314 BLAKE2B 85a49a6713347741a4f1bef8bdd339645abfbccbe9621de8621b5898586d93d399312794be42834f3338fd70c7408f5d5f314ce03ef332fc0db19e053be70a69 SHA512 4ec0dab3dfe36a1730577abf1ecddfc96194364a1dfaf9cb939686b1621b96d6cefc60b204dd000b7ab017237c32b138cbe15644da5dea4a2406c2bf1a686638
+DIST cinnamon-control-center-4.4.0.tar.gz 3868474 BLAKE2B 88e22670427416139468c35918105cc664c531aa5084636226498a09b27f56300c8541feff8f93a5ec860372436af01fdeb2ca2c0761b34a6f298439538dfb44 SHA512 3f176c067312bad68ed8ce2461937d8e8cd188839ab3cf786fb76930905691b8f5a91d700f1d88d75448eeecfd23b645b77ee15c0ec02e08718f7c9ac800677f
diff --git a/gnome-extra/cinnamon-control-center/cinnamon-control-center-4.4.0.ebuild b/gnome-extra/cinnamon-control-center/cinnamon-control-center-4.4.0.ebuild
new file mode 100644 (file)
index 0000000..e4af163
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes" # gmodule is used, which uses dlopen
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/"
+SRC_URI="https://github.com/linuxmint/cinnamon-control-center/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+colord debug input_devices_wacom +networkmanager +modemmanager systemd"
+REQUIRED_USE="modemmanager? ( networkmanager )"
+KEYWORDS="~amd64 ~x86"
+
+# False positives caused by nested configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+COMMON_DEPEND="
+       dev-libs/dbus-glib
+       >=dev-libs/glib-2.31:2
+       dev-libs/libxml2:2
+       >=gnome-base/libgnomekbd-2.91.91:0=
+       >=gnome-extra/cinnamon-desktop-4.4:0=
+       >=gnome-extra/cinnamon-menus-4.4:0=
+       >=gnome-extra/cinnamon-settings-daemon-4.4:0=
+       media-libs/fontconfig
+       networkmanager? (
+               >=net-misc/networkmanager-1.2.0:=[modemmanager?]
+               >=gnome-extra/nm-applet-1.2.0
+               modemmanager? ( >=net-misc/modemmanager-0.7 )
+       )
+       >=sys-auth/polkit-0.103
+       >=x11-libs/gdk-pixbuf-2.23.0:2
+       >=x11-libs/gtk+-3.4.1:3
+       >=x11-libs/libnotify-0.7.3:0=
+       x11-libs/libX11
+       >=x11-libs/libxklavier-5.1
+       colord? ( >=x11-misc/colord-0.1.14:0= )
+       input_devices_wacom? (
+               >=dev-libs/libwacom-0.7
+               >=x11-libs/gtk+-3.8:3
+               >=x11-libs/libXi-1.2 )
+"
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+# libgnomekbd needed only for gkbd-keyboard-display tool
+RDEPEND="${COMMON_DEPEND}
+       systemd? ( >=sys-apps/systemd-31 )
+       !systemd? ( app-admin/openrc-settingsd )
+       x11-themes/adwaita-icon-theme
+       colord? ( >=gnome-extra/gnome-color-manager-3 )
+       input_devices_wacom? ( gnome-extra/cinnamon-settings-daemon[input_devices_wacom] )
+"
+
+DEPEND="${COMMON_DEPEND}
+       app-text/iso-codes
+       dev-util/glib-utils
+       >=dev-util/intltool-0.40.1
+       sys-devel/autoconf-archive
+       >=sys-devel/gettext-0.17
+       virtual/pkgconfig
+       x11-base/xorg-proto
+"
+src_prepare() {
+       eautoreconf
+       gnome2_src_prepare
+}
+
+src_configure() {
+       # cups, documentation, and systemd don't do anything
+       # and have been removed in the next release. So 
+       # disable them for now.
+       gnome2_src_configure \
+               --disable-static \
+               --disable-onlineaccounts \
+               --disable-cups \
+               --disable-documentation \
+               --disable-systemd \
+               $(use_enable colord color) \
+               $(usex debug --enable-debug=yes ' ') \
+               $(use_enable input_devices_wacom wacom) \
+               $(use_enable networkmanager) \
+               $(use_enable modemmanager)
+}
index 64ed8e976b58a1c239731381a611509049ab734e..512549beac5b0dff81c056ac3772747dd82c2ec2 100644 (file)
@@ -5,7 +5,19 @@
                <email>cinnamon@gentoo.org</email>
                <name>Cinnamon Project</name>
        </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>sparky@bluefang-logic.com</email>
+               <name>Matthew Turnbull</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">linuxmint/cinnamon-control-center</remote-id>
        </upstream>
+       <use>
+               <flag name="modemmanager">Enable support for mobile broadband devices
+                       using <pkg>net-misc/modemmanager</pkg></flag>
+       </use>
 </pkgmetadata>