dev-python/batinfo: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Wed, 17 Feb 2016 08:28:45 +0000 (09:28 +0100)
committerJustin Lecher <jlec@gentoo.org>
Wed, 17 Feb 2016 08:57:11 +0000 (09:57 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/batinfo/Manifest [new file with mode: 0644]
dev-python/batinfo/batinfo-0.3.ebuild [new file with mode: 0644]
dev-python/batinfo/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/batinfo/Manifest b/dev-python/batinfo/Manifest
new file mode 100644 (file)
index 0000000..9261aaa
--- /dev/null
@@ -0,0 +1 @@
+DIST batinfo-0.3.tar.gz 3951 SHA256 2991715439e7b48300eb539e2cf3faffe3c9d8a876197078c68616b97f9fdf3f SHA512 822e8e70f14a7f08713028ebc8b41aef6d9256984a6a381af11e5b36980a355636bc21d8b21753f4dabd20e38becf6152c623134a65109593ccba019afe3f3f3 WHIRLPOOL 85ce789aca7806ae07856b1e3a64afd07c2ab3a91627a7266ddfc1bde49068d62a1b970dd9dc329d6d696f923d3b019e83047329a0686ae8b26907b70d4b2883
diff --git a/dev-python/batinfo/batinfo-0.3.ebuild b/dev-python/batinfo/batinfo-0.3.ebuild
new file mode 100644 (file)
index 0000000..0a6fd06
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python lib to retreive battery information"
+HOMEPAGE="https://github.com/nicolargo/batinfo http://pypi.python.org/pypi/batinfo"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/batinfo/metadata.xml b/dev-python/batinfo/metadata.xml
new file mode 100644 (file)
index 0000000..af930ad
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">batinfo</remote-id>
+    <maintainer status="unknown">
+      <email>nicolas@nicolargo.com</email>
+      <name>Nicolas Hennion</name>
+    </maintainer>
+  </upstream>
+</pkgmetadata>