old
authorMike Frysinger <vapier@gentoo.org>
Thu, 21 Dec 2006 03:29:23 +0000 (03:29 +0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 21 Dec 2006 03:29:23 +0000 (03:29 +0000)
app-editors/nano/files/digest-nano-2.0.1-r1 [deleted file]
app-editors/nano/files/nano-2.0.1-bad-path.patch [deleted file]
app-editors/nano/nano-2.0.1-r1.ebuild [deleted file]

diff --git a/app-editors/nano/files/digest-nano-2.0.1-r1 b/app-editors/nano/files/digest-nano-2.0.1-r1
deleted file mode 100644 (file)
index d2664d8..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8abe33be6816ad9acd17391806b42d92 nano-2.0.1.tar.gz 1299203
-RMD160 bce343f9f31c1cc63bd4b37a66fefcaa159a11cf nano-2.0.1.tar.gz 1299203
-SHA256 6af1a2081c6303008163719b9012b403b461fb07991b5603ac28a820494741e2 nano-2.0.1.tar.gz 1299203
diff --git a/app-editors/nano/files/nano-2.0.1-bad-path.patch b/app-editors/nano/files/nano-2.0.1-bad-path.patch
deleted file mode 100644 (file)
index e654729..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-fix from upstream
-
-diff -ur nano-2.0.1/src/files.c nano-2.0.1-fixed/src/files.c
---- nano-2.0.1/src/files.c     2006-11-09 21:47:11.000000000 -0500
-+++ nano-2.0.1-fixed/src/files.c       2006-12-15 00:57:10.000000000 -0500
-@@ -1871,8 +1871,9 @@
-           if (append == OVERWRITE) {
-               char *full_answer = get_full_path(answer);
-               char *full_filename = get_full_path(openfile->filename);
--              bool different_name = (strcmp(full_answer,
--                      full_filename) != 0);
-+              bool different_name = (strcmp((full_answer == NULL) ?
-+                      answer : full_answer, (full_filename == NULL) ?
-+                      openfile->filename : full_filename) != 0);
-               struct stat st;
-               bool name_exists;
diff --git a/app-editors/nano/nano-2.0.1-r1.ebuild b/app-editors/nano/nano-2.0.1-r1.ebuild
deleted file mode 100644 (file)
index 7a5b2cd..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.1-r1.ebuild,v 1.2 2006/12/20 19:51:44 grobian Exp $
-
-#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
-#ECVS_MODULE="nano"
-#ECVS_AUTH="pserver"
-#ECVS_USER="anonymous"
-#inherit cvs
-
-MY_P=${PN}-${PV/_}
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/"
-SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug justify minimal ncurses nls slang spell unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2
-       nls? ( sys-devel/gettext )
-       !ncurses? ( slang? ( sys-libs/slang ) )"
-PROVIDE="virtual/editor"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-bad-path.patch
-       if [[ ! -e configure ]] ; then
-               ./autogen.sh || die "autogen failed"
-       fi
-}
-
-src_compile() {
-       local myconf=""
-       use ncurses \
-               && myconf="--without-slang" \
-               || myconf="${myconf} $(use_with slang)"
-
-       econf \
-               --bindir=/bin \
-               --enable-color \
-               --enable-multibuffer \
-               --enable-nanorc \
-               --disable-wrapping-as-root \
-               $(use_enable spell) \
-               $(use_enable justify) \
-               $(use_enable debug) \
-               $(use_enable nls) \
-               $(use_enable unicode utf8) \
-               $(use_enable minimal tiny) \
-               ${myconf} \
-               || die "configure failed"
-       emake || die
-}
-
-src_install() {
-       emake DESTDIR="${D}" install || die
-
-       dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
-       dohtml *.html
-       insinto /etc
-       newins doc/nanorc.sample nanorc
-
-       insinto /usr/share/nano
-       doins "${FILESDIR}"/*.nanorc || die
-       echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
-
-       dodir /usr/bin
-       dosym /bin/nano /usr/bin/nano
-}
-
-pkg_postinst() {
-       einfo "More helpful info about nano, visit the GDP page:"
-       einfo "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
-}