media-sound/a2jmidid-{9,9999}: bump + added live
authorMiroslav Šulc <fordfrog@gentoo.org>
Wed, 13 Nov 2019 09:49:45 +0000 (10:49 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 13 Nov 2019 09:52:39 +0000 (10:52 +0100)
1) changed to live project on github.com
2) ebuild rewritten to use mason
3) EAPI-7
4) added BDEPEND
5) updated DOCS

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/a2jmidid/Manifest
media-sound/a2jmidid/a2jmidid-9.ebuild [new file with mode: 0644]
media-sound/a2jmidid/a2jmidid-9999.ebuild [new file with mode: 0644]

index 28e71223b1109e7edfb85f54e5877b8b0aa3f4e9..d5e808090f52832065de637f32916e450f5bc591 100644 (file)
@@ -1 +1,2 @@
 DIST a2jmidid-8.tar.bz2 162764 BLAKE2B 4c173d458bc9bf393496bc53dcd92e796826386f3d2704f6d1fc108dd7e4fb660271cc2befec655b516dd669189fb01c23576fdd39c1c23b485346390edfb0a7 SHA512 6182a295462ae587461ca395d85c956523bfecd113d031d0ae8a9f304fc3d41f6a5097b3a1a9fc06bd0eef7fe08a4b3c116a3361ff9e63468c3e40b736215592
+DIST a2jmidid-9.tar.gz 47925 BLAKE2B ad079e76a54f56ee8f82150c306f91aead52f86632978ea6f3376a0bf163744379210b34701b39da4ee14fc4d8a1c6be82d1052abeb8ccf79410bc242d174d62 SHA512 5bd13b6904ed68c5bfe40ca516fd49b7eb4d4a946b9908ee04687265848734c8e1a81579f0f1a5bd0752595be8858dc748da10487b7f366394c09a5ffc7d5e5c
diff --git a/media-sound/a2jmidid/a2jmidid-9.ebuild b/media-sound/a2jmidid/a2jmidid-9.ebuild
new file mode 100644 (file)
index 0000000..8879e05
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
+SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+BDEPEND="
+       virtual/pkgconfig
+"
+CDEPEND="
+       ${PYTHON_DEPS}
+       media-libs/alsa-lib
+       virtual/jack
+       dbus? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+       local emasonargs=(
+               -Ddisable-dbus=$(usex dbus false true)
+       )
+
+       meson_src_configure
+}
diff --git a/media-sound/a2jmidid/a2jmidid-9999.ebuild b/media-sound/a2jmidid/a2jmidid-9999.ebuild
new file mode 100644 (file)
index 0000000..c3d3a8e
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson git-r3
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
+EGIT_REPO_URI="https://github.com/linuxaudio/a2jmidid.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus"
+
+BDEPEND="
+       virtual/pkgconfig
+"
+CDEPEND="
+       ${PYTHON_DEPS}
+       media-libs/alsa-lib
+       virtual/jack
+       dbus? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+       local emasonargs=(
+               -Ddisable-dbus=$(usex dbus false true)
+       )
+
+       meson_src_configure
+}