x11-apps/xinit: Fix postinstall message
authorMatt Turner <mattst88@gentoo.org>
Mon, 9 Mar 2020 01:50:51 +0000 (18:50 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 9 Mar 2020 02:05:42 +0000 (19:05 -0700)
Closes: https://bugs.gentoo.org/710294
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-apps/xinit/xinit-1.4.1.ebuild

index 70f4ab1c68aec83177f4f078dd385f8bc7929eac..cd467fa426af42337f9be922f0acc1d456ed49bd 100644 (file)
@@ -53,7 +53,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if ! has_version 'x11-apps/xinit'; then
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
                ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
                ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
                ewarn "any executable. When you run startx, it will run this as the login session."
@@ -64,11 +64,13 @@ pkg_postinst() {
                ewarn "    env-update && source /etc/profile"
        fi
 
-       if has_version "<${CATEGORY}/${PN}-1.4.1"; then
-               ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
-               ewarn "home directory but rather are created in \$TMPDIR (typically /tmp).  The change"
-               ewarn "is transparent for most of users, however those that use runtime temporary"
-               ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
-               ewarn "not to remove the 'serverauth.*' files."
-       fi
+       for v in ${REPLACING_VERSIONS}; do
+               if ver_test "$v" "-lt" "1.4.1"; then
+                       ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+                       ewarn "home directory but rather are created in \$TMPDIR (typically /tmp).  The change"
+                       ewarn "is transparent for most of users, however those that use runtime temporary"
+                       ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+                       ewarn "not to remove the 'serverauth.*' files."
+               fi
+       done
 }