net-irc/irssi: finally remove Perl unconditional build dependency.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 24 Aug 2018 10:02:14 +0000 (12:02 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 24 Aug 2018 10:02:54 +0000 (12:02 +0200)
GENTOO_DEPEND_ON_PERL="no" is now set just before the inherit phase to
allow irssi to be built without linking to Perl unconditionally.

Also swapped the eutils eclass inherit in favour of ltprune.

Courtesy of Brian Evans <grknight@gentoo.org>.

Closes: https://bugs.gentoo.org/664386
Package-Manager: Portage-2.3.40, Repoman-2.3.9

net-irc/irssi/irssi-1.0.7-r1.ebuild [new file with mode: 0644]
net-irc/irssi/irssi-1.1.1-r1.ebuild [new file with mode: 0644]
net-irc/irssi/irssi-9999.ebuild

diff --git a/net-irc/irssi/irssi-1.0.7-r1.ebuild b/net-irc/irssi/irssi-1.0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..5dfd52e
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL="no"
+
+inherit ltprune perl-module
+
+# Keep for _rc compability
+MY_P="${P/_/-}"
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="https://irssi.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_/-}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+perl selinux socks5 +proxy libressl"
+
+CDEPEND="
+       sys-libs/ncurses:0=
+       >=dev-libs/glib-2.6.0
+       !libressl? ( dev-libs/openssl:= )
+       libressl? ( dev-libs/libressl:= )
+       perl? ( dev-lang/perl:= )
+       socks5? ( >=net-proxy/dante-1.1.18 )"
+
+DEPEND="
+       ${CDEPEND}
+       virtual/pkgconfig"
+
+RDEPEND="
+       ${CDEPEND}
+       selinux? ( sec-policy/selinux-irc )
+       perl? ( !net-im/silc-client )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       econf \
+               --with-perl-lib=vendor \
+               --enable-true-color \
+               $(use_with proxy) \
+               $(use_with perl) \
+               $(use_with socks5 socks)
+}
+
+src_install() {
+       default
+       use perl && perl_delete_localpod
+       prune_libtool_files --modules
+}
diff --git a/net-irc/irssi/irssi-1.1.1-r1.ebuild b/net-irc/irssi/irssi-1.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..5dfd52e
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL="no"
+
+inherit ltprune perl-module
+
+# Keep for _rc compability
+MY_P="${P/_/-}"
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="https://irssi.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_/-}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+perl selinux socks5 +proxy libressl"
+
+CDEPEND="
+       sys-libs/ncurses:0=
+       >=dev-libs/glib-2.6.0
+       !libressl? ( dev-libs/openssl:= )
+       libressl? ( dev-libs/libressl:= )
+       perl? ( dev-lang/perl:= )
+       socks5? ( >=net-proxy/dante-1.1.18 )"
+
+DEPEND="
+       ${CDEPEND}
+       virtual/pkgconfig"
+
+RDEPEND="
+       ${CDEPEND}
+       selinux? ( sec-policy/selinux-irc )
+       perl? ( !net-im/silc-client )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       econf \
+               --with-perl-lib=vendor \
+               --enable-true-color \
+               $(use_with proxy) \
+               $(use_with perl) \
+               $(use_with socks5 socks)
+}
+
+src_install() {
+       default
+       use perl && perl_delete_localpod
+       prune_libtool_files --modules
+}
index 7c30d8608ca74e85733f1be23113735ac8c84866..127644c7dd8b3ec84e4dc86c7ae868259237e704 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
 
+GENTOO_DEPEND_ON_PERL="no"
+
 inherit autotools perl-module git-r3
 
 EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"