sci-mathematics/gp2c: new version 0.0.11.3.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 6 Mar 2020 13:54:19 +0000 (08:54 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 6 Mar 2020 13:54:19 +0000 (08:54 -0500)
Upstream bugfix release gp2c-0.0.11pl3. The most interesting thing
here Gentoo-wise is support for gcc-10.x (-fno-common).

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-mathematics/gp2c/Manifest
sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild [new file with mode: 0644]

index 28aa36077e491b78fe909e0b34169cf009bc5add..f69c31f8cc423f4f2ed4bd2ecfb2b05d1d49d719 100644 (file)
@@ -1 +1,2 @@
 DIST gp2c-0.0.11pl2.tar.gz 851845 BLAKE2B 599469af3e9975270e6d9f88c1209ee3da9ae9ab9bfc90abf2431e00d553d427c15a509278b099a133262b6d02d6fa3f06090bd0083c46c9488e697dc5da5245 SHA512 20f7fc61480a70d3f8811d7881e0f386a1ced522b5c538443dc0a9fe3332d37a67ba68441eb512b5fefdb761e232f9316704fa456a311651161da7b4653ca4b7
+DIST gp2c-0.0.11pl3.tar.gz 854003 BLAKE2B 478307b9fa56b8e58a66001bbeac3ce6193a446cb6a339bbd65de9105924fe92a0e9c39302d836c7f3e7d2fe100ac678514d4e7eef1bdb0b880cc55763002864 SHA512 06d3680da739ce13a0a80a88c7b07a9b336acecb95f4841d8e984f1d4b66ad0a3ffe47e2abb77ad7e564fa976d16c468d62e6ddc15ede3beba00db6d92a91d97
diff --git a/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild b/sci-mathematics/gp2c/gp2c-0.0.11.3.ebuild
new file mode 100644 (file)
index 0000000..b731414
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-"$(ver_rs  3 'pl')
+DESCRIPTION="A GP to C translator"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/GP2C/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Perl is run on the build host to compile the descriptions in desc/,
+# see for example desc/Makefile.am.
+BDEPEND="dev-lang/perl"
+
+# This is the first version of pari to put pari.cfg where we expect it.
+DEPEND=">=sci-mathematics/pari-2.11.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       econf --with-paricfg="${EPREFIX}/usr/share/pari/pari.cfg"
+}