dev-python/pytest-lazy-fixture: Fixtures in pytest.mark.parametrize
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Mon, 27 Jan 2020 20:46:24 +0000 (21:46 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Jan 2020 15:31:51 +0000 (17:31 +0200)
Dep of spyder-4.0.1[test]

Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Closes: https://github.com/gentoo/gentoo/pull/14479
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/pytest-lazy-fixture/Manifest [new file with mode: 0644]
dev-python/pytest-lazy-fixture/metadata.xml [new file with mode: 0644]
dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-lazy-fixture/Manifest b/dev-python/pytest-lazy-fixture/Manifest
new file mode 100644 (file)
index 0000000..a64ac48
--- /dev/null
@@ -0,0 +1 @@
+DIST pytest-lazy-fixture-0.6.2.tar.gz 7737 BLAKE2B 5257a19314a1c9bd159222a170e96db12e5f7b99d2bf83fd2db94acda9726f10997a81239763d8b0d5f2b9f2be6b74acf350d996cff09cf413d3a8ac76e2d90c SHA512 d8d159e936937f4b9364e9be7fcb8228497849a1ef342878ecc8471cd3b06782d2c6029365fd1e02f1ff89eb048ccae625b8697dc5048b4dd8fa61d839ca3f36
diff --git a/dev-python/pytest-lazy-fixture/metadata.xml b/dev-python/pytest-lazy-fixture/metadata.xml
new file mode 100644 (file)
index 0000000..443a727
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>andrewammerlaan@riseup.net</email>
+    <name>Andrew Ammerlaan</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.2.ebuild
new file mode 100644 (file)
index 0000000..de6b1f4
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="It helps to use fixtures in pytest.mark.parametrize"
+HOMEPAGE="https://github.com/tvorog/pytest-lazy-fixture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/flake8[${PYTHON_USEDEP}]
+       dev-python/tox[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest